Workflow sometimes execute timeout

Describe the problem/error/question

The workflow sometimes it is OK and completed within a few seconds. Sometimes it exceeds 2m and prompts 2.05m after the execution fails。

What is the error message (if any)?

The incorrect node prompt is gateway 504 timeout。

I want to know, what does a timeout of 2.05m mean? Where can I modify this configuration?

Information on your n8n setup

  • n8n version: 1.3.0
  • Database (default: SQLite): postgresql
  • n8n EXECUTIONS_PROCESS setting (default: own, main): queue
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker

Hey @superhuahua,

Welcome to the community :raised_hands:

It looks like whatever service you are talking to is returning a 504 error, This is likely to be an issue with whatever you are working with and not directly an n8n issue.

To possibly help with this you could try setting the retry option in the node settings so it can retry, If you see this a lot it could be worth raising as an issue with service you are using directly.

Hey Jon, thank you for your help. This error status is already set according to the configuration you mentioned, and this error will still occur.
I also think there is a problem with the gateway, but now I want to know where the timeout of 2.05m is set? Because every time the status is failed, the n8n display is 2.05m.

1 Like

Hey @superhuahua,

That could be the timeout on the gateway / proxy unless you have any of the workflow timeout options set.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.