Workflow won't end only after killing the process

I am trying to build a custom node for n8n and I am following this tutorial.

When running the workflow execution does not end and keeps spinning with no errors. When pressing the pause button the error in the browser’s console is TypeError: Cannot read properties of undefined (reading 'workflowData') and the terminal’s output is ERROR RESPONSE ResponseError: Execution not found at /usr/lib/node_modules/n8n/src/Server.ts:2378:12 at /usr/lib/node_modules/n8n/src/ResponseHelper.ts:155:17 { httpStatusCode: 404 } Attempt to read execution was blocked due to insufficient permissions

When I stop the server with cmd+C executions green and shows that it’s complete but only after killing the processs.

The workflow I am testing is just a function node that returns a value but same happens even without any nodes.

To share my exact process since I am new to JS/TS and maybe missing something in the process.

I have tried the same process with Windows 10 , WSL on Ubuntu 20.04 on a clean machine and I still get the same error.

No enviromental variables changed , even though I tested the execution process to change it to main with no sucess on changing the error.

  • n8n version:latest(0.192.2)
  • Database you’re using (default: SQLite):SQLite
  • Running n8n with the execution process [own(default), main]:own
  • Running n8n via [Docker, npm,, desktop app]:npm

Hi @gagrinasg, I am using Windows myself but can’t reproduce this problem I am afraid.

Can you run n8n workflows without your custom node code? Which version of Node.js are you using?

Hey @MutedJam , thanks for the quick reply. I am using Node version 16.15.1.
I am pretty sure error is related to building the app since I tried with a fresh WSL with no added code. Even without linking the starter node repo, I get the same behavior.

I don’t know if this is relevant but my Desktop App(0.174.0) works pretty well. I tried to install this version with npm but still had the same results , that’s why I think this is a problem with compilation/building.

Hm, I just tried running npm install n8n -g followed by n8n start on WSL2 Ubuntu 20.04 with Node.js 16, but didn’t have any problem running an empty workflow:

Console output also looks as expected:


Is there a chance you have some firewall preventing local applications from talking to ports on your host.

I know @marcus is a fellow Windows user, perhaps he has any additional ideas here?

Hey G,
I tried out n8n start with npm install n8n -g with version 0.192.2 and everything works as expected. I am working every day with version npm version 0.192.2 for several days now and didn’t run into any problems. Recently started with a fresh .n8n home directory also without any problems. Working with our most recent n8n-nodes-starter project also works as expected.

This seems to suggest it does not have anything to do with linking the n8n-nodes-starter project.

Can you delete/backup your .n8n home folder, make a fresh install of n8n and try again?

npm uninstall n8n -g
npm install n8n -g

@MutedJam Probably not a firewall issue but I will look into it in a different PC to exclude this issue for sure, since I already tried multiple ports to run n8n.

@marcus Tried your suggestion but still the issue remains. It is worth noting that with this suggestion n8n updated from 0.192.2 to 0.193.2.