Workflow won't stop and can't be stopped


Describe the issue/error/question

I’m having trouble on one of my workflows. It never stop and have many instances running, causing performance issue after some hours (i think).

If I click on “Stop execution”, it result to a 524 HTTP error code (timeout error).

I’m wondering how can we force/kill these blocked executions. It is happening on some other workflow, but not that much as this one.

What is the error message (if any)?

If I click on “Stop execution”, it result to a 524 HTTP error code (timeout error).

Please share the workflow

Share the output returned by the last node

No output because the execution is still running…

Information on your n8n setup

  • n8n version: 0.222.0
  • Database you’re using (default: SQLite): How can I be sure ? I think PostgreSQL
  • Running n8n with the execution process [own(default), main]: default
  • Running n8n via [Docker, npm,, desktop app]: Docker compose (customized)

Hey @Locos,

This is something we are aware of and should be resolved in the next release, For now it would be worth using an earlier version of n8n like 0.220.1



Does the v0.222.1 should fix it ?
For now, I’ve tested and still have unfinished executions.

Hey @Locos,

It should fix some issues but not specifically that one.

Hi @Jon ,

I’m getting less workflow in this case. Now I’m checking for some of them, if they’re already executed in background (using old rest api).

But today, I just had a similar issue. One of my workflow, has reached :

So it will not be executed anymore, because it is running constantly. We can’t stop/remove it.

Did you found the cause of this trouble ? If yes what we’ve to take care about ?

EDIT : I’ve tried to stop the execution, remove the execution through the web interface or the API, it is always telling me that the resource doesn’t exist. But it is listed.


Hey @Locos,

What version of n8n are you running now?

@Jon the v0.225.2, not yet updated to 0.226.2

Have you tried restarting n8n? It could be that it wasn’t able to update the database.

1 Like

we had the same problem, we solved it by opening the db and deleting the row from the table “execution_entity”

Are there any instructions on how to do this?

Hi @Stiehla - you might want to take a look at my two posts in this thread, which will link you to a tool you can use to access the database, and what you’re looking for:

There’s a post underneath with screenshots, as well :+1:

Oh ok! So you mean, if I get some “Database is locked/busy”, means some workflow cannot stop them current execution and have a pending status

Good to know!

n8n Version1.0.3
still broken

@mikeon working for me still, What database are you using and are you using queue mode?

I’m getting it too on v0.228.1 using the default mode and SQL Lite database if it can help you

Hey @Locos,

For you does the n8n log show anything? It could be that the workflow process crashed and the database has just not updated. Restarting the container may help with this.

@Jon not sure about queue mode. But using sqlite.
It is indeed a matter of db not updated as restarting the container has not fixed it. It just shows as running and cannot stop.
I’m guessing there must be possible to just update those records in the database when I click stop if there is no underlying process running.

I’m having the same issue, using n8n version 1.1.1, and postgres as db. Is there already a solution to this problem? Restarting the container didnt change anything.

Hey @strongbow,

Welcome to the community :cake:

Rather than restarting can you try stopping the container then starting it again, I have found that with docker sometimes restarting doesn’t fully stop it.

Hi @Jon , thanks for the super-fast response. To make sure, I also did that (I turned off the DigitalOcean droplet and then turned it on again) - but still, the workflow is still shown to be running…