Workflows fail when triggered, but succeed when run manually

A recent upgrade to n8n has broken several workflows in our system that were previously working well.

One such workflow does some date math that previously worked. Here it is returning null:

When I manually execute this node, it successfully computes the difference between the dates.

I moved to the :next version 0.225.2 after reading some recent release notes, but this hasn’t resolved the issue.

n8n is self-hosted on linux using docker / docker-compose

1 Like

Welcome to the community @browland !

Sorry to hear that you have problems. Do you know which version you used before?

Thanks! n8n is a terrific product.

This worked for many versions over the past several months. I think the last version it worked on was 0.218.0. Then I updated last week and it stopped working, which I believe was 0.223.0. I updated yesterday, and also tried updating to :next. Those exhibit the same behavior.

1 Like

Thanks a lot, that is great to hear that you generally enjoy it even if it it seems like something got messed up.

Where do the values from DateCreatedUtc come from? Do you know of what type they are? Assume it is not a String?

It’s coming from a datetime field in sql server. It is presented to this workflow step as a string and then converted. It does work properly when I manually run the individual step, but not when the entire workflow is triggered automatically.


Thanks a lot @browland! Could reproduce it and found a problem that got introduced with 0.221.x by a feature that was supposed to reduce the memory required by the Code-Node. Apparently it has also other unintended consequences. I talked with @netroy about it, he will have a deeper look.


Ok, thanks for looking at that. We have noticed a couple of other problems after this update so perhaps these are related. For instance:

Thanks @jan and @netroy. Let me know if you open an issue for this; I can track that rather than ask you about it.

@browland we released a potential fix for this in 0.226.0. Can you please try upgrading, and tell us if it fixes the issue?

1 Like

No, sorry, I’m still seeing the same issue.

Hi @netroy, 0.226.0 didn’t resolve the issue. We downgraded to 0.218.0 and our broken workflows are working again properly.

(We did find that some more recent nodes in other workflows broke as part of this downgrade and we had to recreate some of them.)

Let me know if there is any other information I could provide you that would help identify this. Thank you for your help!

New version [email protected] got released which includes the GitHub PR 6086.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.