Workflows randomly failing

Hello,

I recently re-installed n8n on a new server and migrated all Workflows. After importing all the json files, I created all the Credentials I had previosly configured on the old server.

What is happening is that sometimes the Workflows are failing with a error as the following:

ERROR: Could not find any entity of type "CredentialsEntity" matching: { "id": "11", "type": "theHiveApi" }

What is strange is that:

  • if I run it manually the workflows run without any problems;
  • this doesn’t happen on every (scheduled) execution. For instance for workflows that run every 10 min, this kind of happens once every one or two hours.

For what I understand this error is related to the credentials object. I’ve already tried deleting the previosly configured Credentials object (e.g. for The Hive) and create it again.

Any ideas?

Kind regards,
Rob

Information about the n8n setup:

  • n8n version: 0.185.0
  • Database: SQLite
  • Running n8n with the execution process: own(default)
  • Running n8n via: npm

Hi @robjennings, I am sorry to hear you’re having trouble here.

Seeing that you have already re-created your credentials, is there a chance one of your nodes has not been updated to use new credentials? Perhaps in a branch of your workflow that isn’t running every time, but just when a specific condition is met?

Hello @MutedJam,

Thanks for your response. I thought of that, however, the Workflow that fails more often is always failing on the same node. On that node, I’ve edited and removed the access credentials, and on the same window, I’ve hit “- Create New -”.

Same result. It’s strange.

Kind regards,
Rob

This is odd indeed. If you delete the node and re-create it from scratch (rather than copying/importing), does that solve the problem for you?

To be honest I havent tried that, since the node has several dynamic values and I didn’t want to just go over all the trouble.

I will do it and let you know if I’m still experiencing this.

Thanks once again.

Kind regards,
Rob

@MutedJam after deleting several Credential Objects and starting all over, it appears the problem is gone.

I also chose different names for the objects (just in case).

Thanks very much.