Xero node returning error on "Return all"

Hi,

I’ve started using N8N (self hosted) to automate a few tasks.

I tried to get all customers from Xero with the xero node.

If i tell it to receive 100, it works, it shows up to 100 contacts. If i ask it to “return all” i get the following error:

403 - {“Type”:null,“Title”:“Forbidden”,“Status”:403,“Detail”:“AuthenticationUnsuccessful”,“Instance”:“2c48bcc4-2dc5-409e-9e3e-8d02cf3fdffc”,“Extensions”:{}} - 403 - {“Type”:null,“Title”:“Forbidden”,“Status”:403,“Detail”:“AuthenticationUnsuccessful”,“Instance”:“2c48bcc4-2dc5-409e-9e3e-8d02cf3fdffc”,“Extensions”:{}}

i saw someone else have this problem and apparently it went away. I saw that last week, had that issue. i tried again today and it’s still there.

Any light to help solve this, would be great.

Thanks

Version 1.26.0 ( i see 1.27.2 is released, and will update)
Database: Default
running on docker
execution process would be default
OS: ubuntu server LTS

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Updated, thanks!

There’s no answerr in that thread ??

Hey @paulyy,

The issue in the other thread resolved itself and it was not related to n8n in the end and was instead something funky with Xero. I suspect this could be a similar issue here but it woudl be worth an update just to be safe.

Hey @Jon

Just updated, same issue.
no issues anywhere else using xero. as soon as i check the “Return All” box, it throws that error trying to get all contacts.

Hey @paulyy,

That is the same as when this was reported before, Everything was fine apart from the Get All then it suddenly started to work.

Do you have a lot of items going into your Xero node or is it the first / second node in the workflow?

Hey @Jon

Exactly the same.
And yes, i can do everything (that i have tried) create invoice, create contact. get 100 contacts. update invoice etc.

as soon as i get it to get more than 100, that’s when the error comes.

Its the 2nd node. 1st is a trigger. goal was to get all contact into a MySQL db.

Hey @paulyy,

That is unusual, I will check on Monday when I get back to see if we have an issue although I am not aware of any changes to the Xero node.