Zoho CRM latency in basic queries

The ‘Get Many’ Accounts node for Zoho CRM is taking a long time to pull in data. This is just for 5 records.

Execution Time: 128322 ms

Information on your n8n setup

  • n8n version: 0.221.2
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: ???
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: cloud

When I try pull ALL accounts, as my workflow calls for, the execution seems to run indefinitely. I have had it running for 5 minutes. I see the API usage rising in the Zoho API dashboard but no data in n8n.

I tried setting the limit to pull 200 records and the data arrived after Execution Time: 130969 ms
The Zoho API docs make mention of a 200 record limit using one of their query APIs so I tried this with 201 records, but that did execute with a similar execution time to above.

Getting a single record by id takes just Execution Time: 620 ms

There is something about pulling all records (about 18,000 in my test case) that is taking in inordinate amount of time.

Hey there @hndmn - Welcome to the community! I’m sorry to see that you’re running into this.

I’ve just tested this on my own n8n cloud instance and was not able to replicate this behaviour - I was able to quickly fetch over 200 accounts (as well as quickly create those 200+ accounts through n8n), so I’m not too sure why you’re running into this.

Have you shared your full workflow, or are there more nodes in your workflow than what you’ve shared? Also, are you sending multiple items to the Zoho node as this would perhaps cause a loop?

For reference, here’s my copy of your query, which was able to successfully fetch over 200 accounts:

1 Like

Thanks for confirming this @EmeraldHerald good to know it is working as expected for you. Here is what I see.

The Zoho CRM node in question is only preceded by a schedule node. There is a lot after the Zoho node, but that wouldn’t affect it, I’m thinking.

Comparing your example to mine, it looks like I have the same setup for the Zoho CRM node. I chatted with Zoho support yesterday to see if there was anything on their end that might be impacting, but they said no. I know every production Zoho instance has varying API limits based on contracts, but to my knowledge that only caps total calls not the rate of fetching data. Currently don’t have any good theories as to why the difference.

I have been running the node by itself during testing. I haven’t tried manually executing the full workflow to trigger the query, but will do so today. I’m also testing today on an empty Zoho sandbox and I will swap out my schedule node for a manual click node just to mimic your example exactly.

Thanks for getting back to me, @hndmn!

The only thing I could think of that might work in testing is to use the HTTP request node to try to make the request manually - I’ve done that here, and also had some pretty speedy results:

The logic behind that would be to remove any n8n wrapper to try to see what happens when you send a plain request through the API and see what comes back. You’ll need to grab the URL for your region from this Zoho documentation.

Can you also confirm the Zoho region you’ve picked? I’m based in Europe so I’ve been testing on their Euro API instance, I’m not sure if this would be affecting you based on region.

Let me know if that helps you troubleshoot!

OK. I use the US region. I’ll try the HTTP method on the full sandbox and see if that makes a difference. Thank you.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.