Zoho invoice

Hello everyone, I don’t know actually if I’m using this node right, but I’m trying to create new invoices on Zoho Invoice using the Zoho CRM node, which has an Invoice resource (I don’t know if it is the same)
And while trying to retrieve a product from the list, I get this:

Also, when I try to get all invoices, this error appears:

This is the workflow


ERROR: Bad request - please check your parameters

the module name given seems to be invalid

NodeApiError: Bad request - please check your parameters
    at Object.zohoApiRequest (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/nodes/Zoho/GenericFunctions.ts:64:9)
    at processTicksAndRejections (internal/process/task_queues.js:95:5)
    at Object.zohoApiRequestAllItems (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/nodes/Zoho/GenericFunctions.ts:85:18)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/nodes/Zoho/ZohoCrm.node.ts:686:22)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/src/Workflow.ts:1270:19)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/src/WorkflowExecute.ts:939:29

Thanks to everyone :smiley:

Normally if it doesnt list any values, it simply cannot connect to the api. Most likely because the credentials are wrong.
The specific error doesn’t seem to be that though.
But to be sure can you double check and see if you can get any data with the get many functionality?

1 Like

Looks like @seba5496 already tried Get Many on one of the screenshots and in the example workflow. That said, I did try running the example node provided and it’s working fine for me:

Checking Zoho’s documentation suggests “The module name given seems to be invalid” could be a permission problem:

  • Resolution: You have specified an invalid module name or there is no tab permission, or the module could have been removed from the available modules. Specify a valid module API name.

Could you verify whether you’re using the latest available n8n version and the Zoho user you are authenticated as has full permissions on all elements related to invoices?

1 Like

I just tested it - we dont use Zoho Invoice but have Zoho CRM.
For any modules we dont have/use I get the same error as the OP
For others it works fine

After reading all the responses, I did some research and I think it is as you said, a permissions issue, however, I have not managed to habilitate the Zoho Invoice module in Zoho CRM (as it seems it is the central connection made in n8n), when I click on the connect account I get this:

But I haven’t found a way of granting explicit access to Zoho Invoice, maybe it is a paid feature(?)
Any ideas?
Maybe there is a way of getting access directly to Zoho Invoice, without “passing through” the CRM(?)
By the way, thanks to everyone for the rapid responses haha.

Hey @seba5496,

I think the problem here is our node is for Zoho CRM and not the standalone Zoho Invoices option, If you don’t have Invoices as a module for your Zoho CRM package then you will run into the issue you are seeing.

For now the best thing I can think of would be to use the HTTP Request node to manually build out the API calls to Invoice.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.