Zulip Integration not bringing streams

Zulip Integration not bringing streams

When selecting “Send to Stream” operation in a Zulip node the “Stream” list is empty.

What is the error message (if any)?

image

Information on your n8n setup

  • n8n version:: 0.17.0
  • Database you’re using (default: SQLite):: PostgreSQL
  • Running n8n with the execution process [own(default), main]:: own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]:: Docker

Hi @GhaziTriki, I am sorry to hear you’re having trouble.

I’ve just tested this on a few different n8n versions (including the latest 0.171.0) but are getting the stream list as expected:

image

Is there a chance this is simply a temporary problem for you? If you use the Refresh List option, do you see your streams?

image

If not, is the Stream/Get All operation working for you?

@MutedJam Same issue I get “data: []” when listing streams. I am using a generic bot by the way. I have tested with an API key and it works. However it is not the proper way using Zulip for automation.

Hi again @MutedJam
I changed my credentials to list the streams them changed back to the bot

It works but this is what I get

image

@MutedJam something else very important. The “topic” should be a free filed. I got rid of n8n restrictions by putting an expression on the values.

Tanks for confirming @GhaziTriki. Can you share how exactly you have configured your bot?

I just tested the Zulip node with a generic bot (without additional settings) and didn’t run into any trouble either:
image

Apart from that, using expressions to overwrite dropdown field values should be fine, I have suggested it a few times here on the forum for other nodes :slight_smile:

Hi @MutedJam I’ve tested again and it is not working. Worse after the upgrade to 0.172.0 I get this error in Zulip node

HTTP Code

ETIMEDOUT

Cause
Data below may contain sensitive information. Proceed with caution when sharing.

{

"message": "connect ETIMEDOUT 95.xxx.xxx.xxx:443",

"name": "Error",

"stack": "Error: connect ETIMEDOUT 95.xxx.xxx.xxx:443 at TCPConnectWrap.afterConnect [as oncomplete] (node:net:1157:16)",

"code": "ETIMEDOUT"

}

I checked and I can ping the zulip server from the n8n server

1 Like

You can ignore that error. I restarted the docker service after a system update and everything went back to normal. However I can’t get streams listed.

1 Like

Hey @GhaziTriki,

I have not used Zulip but does the bot need any special permissions on the Zulip side to be able to read the steams?


Hi Ghazi,
We can’t replicate your error even with the logs you provided. The streams are listed fine and the topics are listed according to the selected stream. Since it is a pre-populated field you can overwrite it using “Add Expression” and thus create a new topic. Then you can remove the expression again and select this topic from the dropdown, should you wish to do so.
If I did not get your request right, please provide more detail and I will do my best to help you out.

1 Like