Zulip Wrong IP

Describe the problem/error/question

I am having trouble with the Zulip nodes. When I try to use any of the nodes I get an error about the wrong IP. I am able to use the HTTP nodes with Curl, the issue is only with the prebuilt node.
Thank you in advance!

What is the error message (if any)?

ERROR: The address is not available, ensure that you have the right IP address

connect EADDRNOTAVAIL ::1:80 - Local (:::0)

Information on your n8n setup

  • n8n version: Latest
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main): Default
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Linux

Hey @Zac_Magee,

That is unusual, in your Zulip credential are you usnig the full url so something like https://zac.zulipchat.com?

Thank you for your fast reply @Jon

So I have set up the credentials in the credentials tab in n8n using my email, the URL of the account and also my API key.

Hey @Zac_Magee,

Does it contain the protocol at the start? On my test account if I just use jon.zulipchat.com it fails with the same error but using https://jon.zulipchat.com works.

This fixed it! Thank you, I never would have thought to check this. No more writing out HTTP requests haha.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.