I had the same error and solved it by removing some executions from the database.
More specifically, executions with status “error” and no “startedAt” value.
You can try this SQL query in your n8n database:
SELECT * FROM execution_entity WHERE "startedAt" IS NULL AND status = 'error'
These executions seems to be replayed by workers and cause these errors with activated workflow.