After "npm update -g n8n" not working


Today I executed this “npm update -g n8n” on server and since then n8n is not working.
I even uninstalled n8n and re-installed n8n it is still the same.

I have tried n8n start and n8n on the terminal but there is no output.
Tried checking port 5678 but there is nothing working. Without output logs I am not sure what is the exact issue.

I event lost my all workflow.

Can someone guide me or help me if someone faced the same issue and how you resolved?

Hey @rahulkathet,

Welcome to the community :cake:

When you run the n8n start command does the terminal go back to a normal prompt or does something else happen? We would typically output something if you use n8n start, What version if n8n did you upgrade from?

Yes it is going back to normal. I installed the latest version but then installed back to the old one.

Are you just using the n8n command or are you running n8n in pm2?

Was using PM2 to run the app, later found the app is not working then removed pm2 and run using n8n or n8n start. But everytime I do that there is nothing coming it is just going back to normal after few sec. The strange thing is this is happening on 2 different servers and on my local Mac it is working perfectly fine.

Are you able to run n8n via Docker? That’s the most stable way to run it, since it makes sure your environment is predictable.

1 Like

I haven’t tried yet, let me try this.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.