Append New Data into to new rows

Describe the problem/error/question

Hi, All.

Any idea on how to append new data into to new row?

I got new data which is “profits”, need to append into new row in google sheets, but I tried many times.
I’m not sure the row must start with the first row in the google sheet or I can choose the specific location.

Hey @Edwin_Wong,

Normally appending data isn’t an issue but in this case you appear to have a non standard format. Typically we look for the first empty row which in this case it has correctly found but your data doesn’t start for a few more.

Have you tried setting the first data row and header row fields to match your template?

Hi, @Jon

Yes. I tried it. But I’m not sure how it works, could you give me some example? Thanks.

Hi @Edwin_Wong, I just gave this a go on my end and it appears you’d have to use “Map Automatically” as the “Mapping Column Mode” setting in your Google Sheets node. Otherwise, n8n would only offer columns defined in the very first row of your sheet, regardless of what’s configured under Data Location on Sheet → Header Row. Not quite sure if that’s an expected limitation or a bug though, but perhaps Jon can confirm once he’s back.

For now you’d have to set up your Google Sheets node like so (this is assuming you’re using the latest version of both n8n and the Google Sheets node):

The 6 in the screenshot above is the header row of the actual table containing the data on my sheet. Now when executing the below example workflow, the data is added in a new row as expected.



Hope this helps!

Hi @MutedJam

First, thanks for your answer.

I’m following the solution that given by you. By right, it should works correctly.

As you can see from this picture above, header row → I set to 16. and the following picture

The result should come out at this row ( 16 )

But the result eventually come out as picture below. I really have no idea regarding this.

Hi @Jon @MutedJam

Actually I do have a question, if I using "Mapping Column Mode is Manually, does it compulsory start from row 1 instead?

Cause I actually is not start from row 1, my data start from row 7, Google Sheet node cannot capture the data if my data start from row 7.

Hi @Edwin_Wong, I suspect this comes down your specific sheet possibly containing more data than meets the eye (formulas or white spaces for example). Can you share the following details please?

  • Your current n8n version
  • An example Google Sheet using which the problem can be reproduced (you can of course redact any confidential data as long as the issue can still be reproduced)
  • An n8n workflow using which the problem can be reproduced

Actually I do have a question, if I using "Mapping Column Mode is Manually, does it compulsory start from row 1 instead?

It seems that way, I could not get the Manual mapping to work when testing this. It’s why my example provided above uses “Map Automatically” and sets the Header Row value.

Hi @MutedJam

Basically, I need to retrieve the data from the first Google Sheet Node (Read W Wallet).

  • Your current n8n version : 1.4.1

Eventually I need to update the data here, but it is not start from row 1 as picture below.

Hi @Edwin_Wong, thanks for sharing your additional screenshot! It seems there is additional data to the left of the previously visible table.

Unfortunately this isn’t a scenario the Google Sheets node currently handles, so I’d suggest you create a separate sheet for your Transaction History table here, without any additional data outside the table.

Hi @MutedJam

I found this. It seems like last time can be works.

By the way, based on the link at above. Is it possible to use app script to do this task?
And also, is it possible that I read the data from google sheet for specific range and then I retrieve this range to create a new spreadsheet?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.