Asignee or Reporter in the list limited to a few

Hello community , I have seen a similar question posted here:"Wrong List" of assignees in Jira Function) but I think it didn’t result in a solution.

I’m having a similar problem in Jira node. I can see a few people in the drop down list for assignee or reporter however it’s limited. Maybe the dropdown has a limit of 50 or something but I don’t know. Also it doesn’t allow me set it with expression from a previous node. Also I can’t add the name statically in the Assignee section.

Do you have any recomendeation how to solve this issue?

Hi @Irem, many thanks for reaching out! From taking a quick look it seems the function loading the users does not implement pagination, so I suspect you’re right here. I’ll make sure to add this to our backlog so we can fix this.

You should still be able to manually specific a static value by using an expression. Can you try select a random available user first and then add an expression to the respective field via the gears icon right next to the field?


1 Like

Hi :wave:
Thanks for your reply.

When I select a random user and click on apply expression I see numbers instead of names (Example: 557058:de149554-35cb-43e4-ba06-d7fb927609f4).

I assume the second part after : is the jira id but not sure what the first part is.

I tried adding the jira id dynamically but it doesn’t accept it

Same when I try with Jira user name dynamically it doesn’t accept. When I try to run the node despite the error I get a bad request

Are you using your own Jira server or the cloud version? For the server version it should be the username of the Jira user (which might not be identical to the display name), for the cloud version it should be the ID.

Before reading it dynamically it’d be good to see if a simple static value works.

I’m using jira Cloud

Also static value doesn’t work. I think because by default I see a drop down and the drop down is limited to some names. My static value is not in the list so I get this error.

Ah yes, you’re quite right. You should still be able to send the request to Jira, even though n8n might complain about not finding the value.

But I can’t :frowning:
I get an error

Hm, tbh Joanna Quintanilla doesn’t look like Jira user ID I have seen before. Could you try opening her profile in Jira directly? This should how the user ID as past of the URL as described here:

Ah sorry understood what you mean. It worked with the id of the user. Thanks for your help! :blush:

1 Like

Awesome, I am so glad to hear that because I was trying to request another Jira trial just now and Atlassian said no :see_no_evil: