Aw, Snap! Something went wrong

Anyone noticed this happening since latest version?


Kind of a hard one to diagnose, but it never happened previously, with either latest N8N or it could be chrome Version 102.0.5005.115 (Official Build) (64-bit)

Hi @wgicio, I’m sorry to hear you’re having trouble here.

I just tried loading [email protected] on Chrome 102.0.5005.115 and didn’t run into any problems.

So my suggestion would be to first verify if this is indeed related to the n8n upgrade, for example by temporarily downgrading again to the previous release.

In the next step you could then verify if this might be related to any extensions you might be running on Chrome (by disabling them 1 by 1 or by using Incognito mode without any extensions).

If the issue still persists at this stage, you might want to test a different browser to confirm if this is a problem with your Chrome installation.

Its an intermittent issue, thought I would post it in case someone else has it and is looking for answers:)

Still sounds very fairly annoying tbh :frowning:

So definitely worth posting and seeing if anyone else has this problem. Even if not it might still be worth following the steps above to rule out some possibly causes of the problem.

1 Like

I am getting Aw snap on chrome frequently after running n8n workflows. Is it because chrome is getting out of memory while processing n8n FE.

My issue stopped for a while however started again with latest issue, I’ve had a few SIGILL crashes.
I have plenty of memory so don’t think its related to that

Hm, I am afraid I can’t reproduce it. Seeing this is happening with the latest version 0.192.2 for you, perhaps @Mutasem has an idea what has changed frontend wise that could cause this behaviour?

Hi, yes, might be a memory issue. is there a specific action that leads to this? If you are hosting, can you try with N8N_DIAGNOSTICS_ENABLED=false flag and see if that helps? Or simply try an adblocker?

1 Like

I often get workflows which use a lot of RAM and CPU when it’s just open, not in the execution state. CPU just keeps on going and going and it never idles unless I close and open it again - It is these workflows that tend to crash

There are no network requests, How do i figure out what it is doing ?

I’ve started to see this a lot on 0.194.0

Not sure how to provide further information. It can happen both when I work on a workflow or when it is just sitting there executing a workflow without me touching it.

I took this screenshot with a workflow that takes about 20 minutes. It never really stops and continue to consume a lot of ressources - not sure if this is related though


nothing is happening on the backend
Chrome CPU usage goes crazy instantly when the tab is visible. Switching to another tab it drops off to basically nothing, not sure if this is a chrome power saving feature.

Hi, i have the same.
Browser - fresh Brave (Version 1.43.93 Chromium: 105.0.5195.127 (Official Build) (64-bit)
n8n.io version 0.194.0
ntb - 40GB RAM, 3060gpu, ryzen 5800H
running n8n on server 4c8g200g
While tab crash, workflow is running on server (looks till finish).

Not adding something useful but just wanted to say that I face this often.
In my observation it happens when when you spending good amount of time executing the workflow, testing and executing again. Which makes it all the more frustrating because you end up losing your unsaved work.

It seems like continuous playing around makes the tab consume too much memory.
Also if I have multiple tabs open all of them crash together, so it seems like the browser is doing something here.

I am not sure what to track or share with you when this happens again - but if anyone of the devs knows what they might be interested in Iooking, I can share.

1 Like

Yes - continous playing. But in my case i have optimized workflow - on the start was reading whole column in excel, then was Split in batch - 1 item. On the end was "remove first line in excel, then all this repeat starting from reading whole column in excel.
After optimization I put reading just one cell (instead of whole column) and removed “Split in batches” node. And no more crashes.
Now i have different problem - many read/write into Google sheets - so I will replace whole flow from sheet to Grist or something like that.

That is interesting, I often have 3 or 4 tabs open for creating examples and testing any issues that come in throughout the day.

The only time I tend to notice something odd is when I am dealing with a lot of data or if I have put my computer to sleep and wake it up then start doing something so most mornings I have to refresh the tab. I had always put it down to some odd browser thing.

In your case is it also after waking your machine up or does it always happen?

I have many tabs opened. But i have 40GB Ram. My computer never sleep :slight_smile:

But - n8n is in my case running on VPS. After crashes I found, that workflow is trying continue run on server till end. But this is bit blind - you cant see flow + finish. Or its possible to run workflow directly in CLI… But as im still debugging and optimizing workflow - I dont use run via CLI at this moment.

Hey @martin_sabo,

I can guess we can rule out the sleep theory, To be honest I don’t think the ram really matters that much as most browsers will limit the memory usage per tab to try and prevent issues from longer running scripts.

In the background it will be fine it is just a UI thing so working out the pattern is going to be key to solving this one. I suspect there is more than just working in the UI all day so some of it could be down to the workflow and the amount of data.

Hi @Jon I think you wrote it -

most browsers will limit the memory usage per tab to try and prevent issues from longer running scripts

If I ran workflow in console - there was tons of data. But - maybe we can hack the browser and allow more memory per tab?

“It seems like continuous playing around makes the tab consume too much memory.”
I call this using n8n

@jon when you say large amounts of data, how much are we talking? the amount were the UI warns that there is a lot to display with an option to “display anyway”

In my case its not anywhere near huge amounts of data, its about “playing around” testing and something as simple as running a http request after a workflow has been open for a while (like 5min) sends the cpu and ram into a death spiral and browser crash

the pinned data tabs have been my saving grace since this started, amazing feature btw