Bug: HTTP request leads to temporary 503

Same node worked as intended before instance update.
I saw issue with HTTP node and tried header with user-agent, but got same errors.

Video here

Unfortunately, there is no option on n8n.cloud to downgrade version : (

  • n8n version:0.148.0
  • Running n8n via n8n.cloud

Hey @RawmanGrey,

I apologies that you faced the issue. Can you share the API you’re trying to make the request to? I am assuming that the data from the API call is huge which results in this issue. Can you confirm the size of the incoming data? If it’s huge, I suggest you try paginating the request.

Hello, @harshil1712 ! Yes, data was big, but not extreme, below 300kb.

It was bad idea to restart instance - now it is offline. In console’s errors it was printed something about cookies in vars.hotjar , may be that’s related…

UPD: few minutes after instance is up again : )

UPD1: confirming, same endpoint with lower amount of data returned went well

UPD2: just made new request and it successfully returned 323kb…

I am glad that it is working now. Though, I am not sure what caused the error in the first place. Tagging @MutedJam for further inspection.

If you face this issue again, please let us know.

Same node with same incoming data has unexpected result: I’ve got same 503 error with temporary unavailable service once again, and after half an hour (without changing a thing) all worked as it should…

For now I’ll just paginate request, but issue is still worth investigating - inconsistent results are scary :pensive:

Any chance you could share what the API is so someone can try and reproduce the issue?

1 Like

Hi @RawmanGrey, we did see some n8n.cloud alerts this morning though (which are now resolved) and I wonder if this might have been related or just a coincidence.

Unfortunately though, I couldn’t find an n8n.cloud account under your forum email. Could you share your n8n.cloud username or email via DM so we know on which instance exactly this happened?

That was a POST call on Notion API https://api.notion.com/v1/databases/<database-id>/query, with filter and sort in the body. I’ll come back to this issue later and will try to reproduce on some open data - that was clearly related to response size.

@MutedJam, hopefully a coincidence, I’ll send my email and post here later if will face same issue again.

BTW, monthly executions count on my account was dropped this morning.

1 Like