[Bug] Loop goes into Done before Loop

Describe the problem/error/question

Loop goes into Done before Loop

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: Beta AI
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): n8n cloud
  • Operating system:

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @Kevin_Lourd,

What is the workflow in the Execute workflow node at the bottom doing?

Hey @Jon :wave:

In my eyes it is a random flow doing some operations, but I may be missing something

Hey @Kevin_Lourd,

If you check the execution log for the sub worklfow is it starting and stopping part way through?

Yes it looks like this.

Once, when I looked in the execution log, I saw that it was stopping in the middle of the sub-workflow for no reason I understood.

Now, when I look in the execution log, I can’t see this part sub-worflow execution

Hey @Kevin_Lourd,

Do you have the subworklfow set to log the executions still?

The sequence is:
1/ It starts with the Loop branch but spend like 0 seconds and stops at the first node. That first node has no log of this “0s pseudo execution”
2/ It goes in the Done branch. Subflows work correctly there
3/ After Done branch, it goes to the Loop branch the correct number of times. Subflows work correctly there
4/ It end in the Done branch again. Subflows work correctly there

I have an execution log! In the case the subflow crash then it logs.
[BETA] n8n - :warning: Import GetFeedback feedbacks from Campaign

It is super weird because only 1 segment is green, in the middle of the subflow, the rest is grey

That is odd, It looks like the supabase node had an error though. You should be able to set the subworkflow to log under the workflows settings that will let us capture more attempts.

Hi @Jon , I confirm that the bug is always there.

  • There is no log of the subworkflow where it lasts 0s, unless I make it crash at the beginning of it. I did went to the subworflow setting and saved “ON” everything possible.
  • Even if there was a bug or anything wierd inside that subworkflow, I don’t understand why it would go to the Done branch before going to the Loop branches

Actually the order is:
1/ Loop branch but without real execution of it
2/ Done branch
3/ Loop branch
4/ Done branch
5/ Loop branch
6/ Done branch
etc.

I am desperate for help :upside_down_face:

Hey @Kevin_Lourd,

I have still not been able to reproduce this, In theory it should wait to loop back round unless we consider any failure a “done” option but I have tried with a few different error options with no luck as well.

Annoyingly as with any bug if it can’t be reproduced it makes it tricky to fix it, Does the same thing happen if you use a smaller workflow or less data maybe?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.