Bug not fixed


i’m referring to the issue here:

As the topic is closed already, i’m opening a new one.

Being on 0.203.1 now the issue stated in the link above is not fixed for me at least on a following workflow:

  • open a workflow
  • execute workflow with pinned data on the first node
  • try to edit some node settings
  • save is not working (workflow was changed by another user)

I’m the only user in my installation. Please help, as the issue prevent me from developing further on the project I have.

Thank you!

Edit: my setup

  • n8n version: 0.203.1
  • Database you’re using (default: SQLite): MySQL
  • Running n8n with the execution process [own(default), main]: main
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Turns out I’m seeing the same error. I’m using npm to run n8n 0.203.1 with the default execution process, with Postgres. I’m most certainly the only user in my deployment. Going back to the Workflows dashboard and clicking on the workflow where I saw this error takes me right back to a blank slate, so workflows are definitely not being saved.

Hi all, I am very sorry for the trouble.

I know our engineering team was discussing this problem the other day. Perhaps @netroy can share an update on this and confirm if any further details are needed here?

I met this bug too. And I simply tested 0.203.1, 0.203.0, both these two version have this bug.
0.202.1 is working properly, I have downgraded to 0.202.1 temporarily.

Oh that’s quite alright! No damage done. I think I’ll try downgrading my n8n installation down to 0.202.1 - is that going to cause any issues with schema migrations?

Thank you @rudimk. Also, from following the internal conversation I can confirm we’ll (temporarily) remove the feature causing these problems with the upcoming release: fix: Disable workflow locking due to issues by krynble · Pull Request #4708 · n8n-io/n8n · GitHub

Got released with [email protected]


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.