Issues with importing and saving workflows

Describe the issue/error/question

Hey guys, I’m new to n8n, but I’ve tried the windows app and set-up a workflow successfully.

I’ve installed n8n via Docker on linux, so that I can have the daemon running all the time. Managing it via the web interface.

I’ve followed the instructions, and got n8n set-up, but I’m getting various errors when trying to import and save workflows.

When I import workflows, they import correctly, but I’m unable to edit any of the nodes. It’s almost like the nodes are read only. I’m able to create new nodes, but just not edit the imported ones.

Secondly, when I create a new workflow, add a couple nodes, and try to save, I get the error: Workflow ID 5 cannot be saved because it was changed by another user.

There’s no other users, it’s just me creating/editing workflows.

I searched on the forum but I haven’t found any threads with people reporting similar issues.

What is the error message (if any)?

400 Bad Request: Workflow ID 5 cannot be saved because it was changed by another user.

Please share the workflow

Not really relevant as it’s the same case with any workflow I have tried exporting from the windows app, or creating via the Docker web app. But here’s one as an example.

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 0.201.0
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: default
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

I tried the same thing today, exporting workflow from local Docker instance on my laptop to production site, by importing the json over there.
The importing process went ok, however clicking on the nodes in order to edit does not have effect. The existing nodes do not open, new nodes DO open
Stefan

I got this error a few times today.
Solution (like always) - save workflow, refresh page - seems to fix every UI error for me

I just tried, but no result here. nodes will not open for editing
Stefan

besides this issue i cannot even move the nodes in the gui, except for the ones I newly add
Stefan

Thanks for verifying the behaviour @sl-tobe

@treyr I can’t save the workflow, as the error states! :sweat_smile:

Hi @WildPress,
we have seen the issue recently and released a fix with [email protected]

Could you upgrade your n8n instance to the latest version 0.202.1 and check if your issue is resolved.

2 Likes

Thanks @marcus, that seems to have worked for the imported workflows!

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.