Can't setup n8n with Docker

Trying to get n8n up and running with Docker Desktop for Windows. Tried using the quickstart code, but getting the error:

    docker: invalid reference format.
See 'docker run --help'.

Can’t understand what I’m doing wrong. Tried pulling down the latest version of n8n, seemed to do so successfully, though I don’t know where it’s pulling to. Any help/guidance for a newby?

Can you post the full command you are running?

@BRPW, welcome to the community.

To confirm, is this the docker command you are running?

docker run -it --rm --name n8n -p 5678:5678 -v ~/.n8n:/home/node/.n8n n8nio/n8n

Yep, that’s the one.

Did you remember to change ~/.n8n to a Windows path? So something like:

docker run -it --rm --name n8n -p 5678:5678 -v C:/Users/Username/.n8n:/home/node/.n8n n8nio/n8n

Hey Jon, I did not. Still beginning my journey into the world of code/programming. Once I’ve downloaded the official image from Docker (or pulled it using CMD), where would I find it?

You can put whatever you want really just make sure it is a local path, I suspect the issue is where ~ is a shortcut on Mac / Linux systems for the current users home directory so assuming your windows logon name is BRPW the command below “should” just work.

docker run -it --rm --name n8n -p 5678:5678 -v C:/Users/brpw/.n8n:/home/node/.n8n n8nio/n8n

I suspect there is probably a windows version of ~ maybe something like %HOME% or $HOME but it might be easier to just manually set a path and see what happens.

1 Like

Hey Jon,

Tried running your code; got the following response:

docker: Error response from daemon: mkdir C:\Users\n8n\.n8n: Access is denied.
See 'docker run --help'.

This is after making the folder C:/Users/n8n/

For clarity, I tried using my normal user folder (my full name with capitals), but got this:

docker: invalid reference format: repository name must be lowercase.
See 'docker run --help'.

Hey @BRPW,

Try using your normal user folder but lowercase it all so maybe c:\users\ben\.n8n if that doesn’t do it I can set up a Windows virtual machine and give it a quick bash and see what happens.

Hey Jon, sorry for the delay.

Tried all lower-case. Still hasn’t worked, I’m afraid.

Morning @BRPW,

Are you getting the same error message? Any chance you send over the full command you are running or DM it if you want.