ClickUp Trigger Node not Working

Hi there, would just like to ask on what would I be doing wrong because my ClickUp trigger node is not working. Access token is good and regular clickup node works.

{
  "nodes": [
    {
      "parameters": {
        "team": "1859510",
        "events": [
          "taskStatusUpdated"
        ],
        "filters": {
          "folderId": "7974568",
          "listId": "18338043",
          "spaceId": "3843643",
          "taskId": "9bxkvh"
        }
      },
      "name": "ClickUp Trigger",
      "type": "n8n-nodes-base.clickUpTrigger",
      "typeVersion": 1,
      "position": [
        400,
        300
      ],
      "webhookId": "ce263fca-3455-49e9-a170-82e373be44cf",
      "credentials": {
        "clickUpApi": "Clickup"
      }
    },
    {
      "parameters": {
        "operation": "append",
        "sheetId": "1p9Gvg8jQhOkoCZrzuxKKmzcx64ZkTTE9S7fITGwYAtc",
        "options": {}
      },
      "name": "Google Sheets",
      "type": "n8n-nodes-base.googleSheets",
      "typeVersion": 1,
      "position": [
        700,
        300
      ],
      "credentials": {
        "googleApi": "swissruigor g drive"
      }
    },
    {
      "parameters": {
        "values": {
          "string": [
            {
              "name": "status",
              "value": "Got it"
            }
          ]
        },
        "options": {}
      },
      "name": "Set",
      "type": "n8n-nodes-base.set",
      "typeVersion": 1,
      "position": [
        550,
        300
      ]
    }
  ],
  "connections": {
    "ClickUp Trigger": {
      "main": [
        [
          {
            "node": "Set",
            "type": "main",
            "index": 0
          }
        ]
      ]
    },
    "Set": {
      "main": [
        [
          {
            "node": "Google Sheets",
            "type": "main",
            "index": 0
          }
        ]
      ]
    }
  }
}

image
I think it has something to do with my webhook URL?

Yes that is correct. If you are testing you need to start n8n with a tunnel. In production you can set the env variable ‘WEBHOOK_TUNNEL_URL’.

1 Like

Alright. Thank you so much. Solved it!