CloudFlare Authentication and Error 403 when running n8n workflows

So typically I use my internal IP address when working on n8n workflows, my webhooks use my external domain and run fine.

I access n8n externally via CloudFlare Zero Trust, so i visit the external domain, authenticate myself with Cloudflare 2FA and i get access to my n8n instance, this all works fine. I have caching disabled, and can log out and log in on n8n without any errors, but when i try to execute a flow i get the following error message.

Which i read it ask, your are not authenticated (error 403)


So i check the logs

however i am logged in, even after signing out and clearing the cache and logging back in again, in the GUI it shows me as signed in.


I can use the API playground using the external domain fine, also

It hasn’t done this before, any ideas?

Hey @RedPacketSec, I am afraid I can’t reproduce this locally or on one of the n8n instances I am running.

You might want to check your webserver access logs (assuming you are running a reverse proxy) with your Cloudflare service enabled vs with the service disabled to check how exactly they manipulate the requests and get an idea of what might need to be changed.

If i start a new flow its fine, its only when i open an existing flow and try to execute it.

there are no error logs on the cloudflare side that i can see