Problem with Webflow API Access

Hello Forum,

I have the problem that N8N is loading and loading, with the Webflow Trigger :slight_smile:. Maybe someone nows the issue. The API is working, N8N find my Page.

Thanks for helpful answers :smiley:

Welcome to the community @Fabian!

I guess you execute the workflow manually. In this case is n8n waiting to receive information from Webflow to display it to you. So after you pressed “Execute Workflow” you then have to perform the event you do listen to. As soon as that did happen, will n8n receive that information and display it to you in the Editor-UI.

Hi @jan unfortunately this doesn’t work, the API finds my Webflow page, when I publish the page , for example nothing happens at n8n :(.

What is the trigger event you using? Are you using the trigger in test mode? Or is the workflow active?

@RicardoE105 I am using the webflow trigger, with the Trigger Form submission, but alos tested with publishing …

I tested everything, active workflow, test mode …

Just tested it and it works fine for me.

Which version of n8n are you using? I tryied again, nothing :(. Loading, Loading …

V0.124.1 but do not think that is the issue. Test something first. If you add a webhook node, and make an http request (with postman for example) to the webhook’s url, does it work?

1 Like

@RicardoE105

{
"code": 401,
"message": "Authorization is required!"

}

Maybe this is the problem? :slight_smile:

But I want an authorizion to prevent that somebody can change n8n :smiley:

Where did you enable the authentication? at the webhook level?

I activated it on the docker level, so that I need to enter username and password, to enter the n8n site. For the webhook I choose no Authentication.

Then why is it the webhook response with 401? If you chose no authentication.

Now I get this every time :frowning:

This is the webhook url:
https://localhost:5678/webhook/271dbeae-75b8-4b1d-bab7-0e59dd80ffbf

{
    "code": 404,
    "message": "The requested webhook \"POST 271dbeae-75b8-4b1d-bab7-0e59dd80ffbf\" is not registered.",
    "stack": "ResponseError: The requested webhook \"POST 271dbeae-75b8-4b1d-bab7-0e59dd80ffbf\" is not registered.\n    at ActiveWorkflowRunner.executeWebhook (/usr/local/lib/node_modules/n8n/dist/src/ActiveWorkflowRunner.js:74:23)\n    at async /usr/local/lib/node_modules/n8n/dist/src/WebhookServer.js:62:24"
}

How are you testing it? How did you set up the webhook node? If you send a GET request but set the webhook to work with a POST request, you will get this error.

image

If you execute the workflow from the editor UI you need to use the test URL. if you activate the workflow when you need to use the production URL.


better but its loading

How did you deploy n8n?

with docker

but now, its working, I got the webhook …

did you follow the instructions here: Server Setup | Docs?