Connection Lost - Local Docker Image


I have tested n8n a while ago and now I have a use case for it.
So what I did was essentially spin the docker image and get started.
But I cannot seem to launch/execute any workflow


I do not have any firewall whatsoever blocking anything
I do not have any errors in the log

Am I missing something?


Hey @yarlanda,

Welcome to the community :cake:

Are you using a reverse proxy at all or are you connecting directly to container on port 5678?

Hello Jon

No am not using any reverse proxy.

Hey @yarlanda,

Does that mean it is a direct connection to the container on port 5678? Normally we only see that message when something is not configured correctly. Can you share how you started n8n and the options you set (removing anything sensitive)?

@Jon Yeah it’s a direct connection to the port 5678

I tried it with my WSL with same result
I tried to spin it up on a Virtual Machine same thing

Here’s my docker compose:

    image: n8nio/n8n
      - "5678:5678"

Let me know if you any additional information


Hey @yarlanda,

Nothing else I can think of that same setup seems to work ok for me :thinking: When it shows that message is there anything in the browser dev console?

Nothing on the console

Nothing on network as well
All status code 200 or 304

Just noticed this GET request is in pending

Hey @yarlanda,

Are you accessing n8n using n8n.local or the IP?

2 possible things you can try is…

Set N8N_PUSH_BACKEND to websocket


Set VUE_APP_URL_BASE_API to http://n8n.local:5678 (if using the default port and the n8n.local address instead of the IP)

At first I was using an IP only
Then I saw someone online having a similar issue and I tried to add some DNS record to access n8n.
Then I realised they had n8n behind a proxy and their issue was entirely different

Ok I’ll try what both arguments

Hey @Jon

It works when I set the N8N_PUSH_BACKEND to websocket
I see this is documented as well here:
Environment variables reference | n8n Docs

But I cannot get around why it does not work with the default “sse” option.
Is my system misconfigured or is there some requirements for SSE to work?
Maybe it needs https connection?

By the way thanks for your help on this.

Hey @yarlanda,

That I am not sure about, for me SSE works but we are changing the default to websocket in v1 anyway.

I suspect it will be some local network setting but I am not sure what it is, could even be something in Docker.

Yeah you’re probably right.
Anyways thanks for your help on this


1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.