Email Node tries StartTLS even when tls is disabled

Describe the problem/error/question

EMAIL Node, TLS Disabled, throws an error. When i check mail server log, i see a starttls issued. which is in this environment not possible.

IF i activate the “Ignore SSL Errors” the email is send.

What is the error message (if any)?

Certificate Expired

Please share your workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version: 1.20.0
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):own
  • Running n8n via (Docker, npm, n8n cloud, desktop app):Docker
  • Operating system:

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

@Martin_Forster , it sounds like SSL option in credentials is redundant. To be honest, I’m surprised to see it there in the first place but not surprised it gets ignored. The control of the protocol used (secure vs not secure) in establishing the connection to the server is rightfully controlled by the Email node itself.

In your case, it looks like the SMTP server does not have a valid SSL certificate but Email node establishes connection via secure protocol by default. Since certificate is invalid the response let the client know of that. Ignoring the warning works as your SMTP allows insecure connections.

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.