SSL Error while executing Send Mail node

Describe the problem/error/question

I use elasticmail for transactional mails. I created credentials normally. Upon executing Send Email node, I received this error:

ERROR: 58BBE053267F0000:error:0A00010B:SSL routines:ssl3_get_record:wrong version number:…/deps/openssl/openssl/ssl/record/ssl3_record.c:354:

HTTP Code
ESOCKET

NodeApiError: 58BBE053267F0000:error:0A00010B:SSL routines:ssl3_get_record:wrong version number:…/deps/openssl/openssl/ssl/record/ssl3_record.c:354:

at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/EmailSend/v2/send.operation.js:226:19)
at processTicksAndRejections (node:internal/process/task_queues:95:5)
at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/EmailSend/v2/EmailSendV2.node.js:87:22)
at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:658:19)
at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:631:53

Even Ignore SSL Issues option doesn’t seem to work. What should I do?

Information on your n8n setup

  • n8n version: 1.7.1
  • Database (default: SQLite): default
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu 22.04.2

Hi @mustafamohsen :wave: In the credential, there’s a TLS/SSL toggle - can you try toggling this to the other option and seeing if that fixes it up?

if it hasn’t, it sounds like you might not have either your mail server or n8n configured correctly - could you share your Docker compose file (and redact any sensitive information that might be in there such as passwords / tokens)?

1 Like

Hi @EmeraldHerald
Yes! Turning off the SSL/TLS switch solved it
Many thanks

2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.