Error 413 Payload too Large

Im getting a weird issue where sometimes my HTTP nodes execute, and sometimes I get a 413 error (Payload too large). I currently have 2 nodes that react this way.

The first one pushes some text to Flowise and receives back a reply. There isnt THAT much text, about 8 lines if i copy it to this text window. If i save and then reload the workflow and run the full workflow the node executes just fine. If i try to run just the node, it fails.

The second one is calling an Airtable API for comments and Ive only been testing with the text being “Test API comment”. This node will only execute when i run the workflow for the first time after reloading it.

Any advice?

After some further testing I find that if i execute the entire workflow, it works fine with no issues. However trying to execute either of these 2 nodes on their own results in the Payload too large error.

Feels like a weird bug, any ways to fix it?

Hi @Nikto655, I am sorry you’re having trouble. I am not quite sure in which context the error appears for you so I don’t know if it’s thrown by Flowise or by n8n here (or perhaps by a webserver somewhere along the way).

On the n8n side of things you can increase the max payload size by setting the N8N_PAYLOAD_SIZE_MAX environment variable to a higher value than the default of 16 MB. Keep in mind that the total payload exchanged between the n8n server and your UI is much bigger than just the example data you’re sending in your 2 HTTP Request nodes (as all input and output data for each node and every single item processed in your workflow would have to be transferred).

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.