Error with Multiple Relations in Notion Node

Describe the issue/error/question

This looks like it may be a bug with some recent changes to the Notion node, but given my newness to N8N, and my lack of fluency in JS, I’m hesitant to just open a bug without some confirmation that this isn’t user error. I’m trying to use the Notion node to create a new database age, with multiple relations, the number of which are not known prior to node execution. Previously, there was a bug where if there was no relation, the page creation failed, so I upgraded to the new version, which is why I suspect this bugfix may have actually caused my current problem. It looks like maybe this line is validating the UID before splitting the list, and thus failing.

What is the error message (if any)?

ERROR: The relation id “39da0f64-fe52-4a50-a38a-a0a8453e9241,465dde93-9b7c-4fd9-ae32-0863b4993d53,a68817d7-d8e2-4eff-8f59-e0ec852d6a8a,cc6d134b-cf21-45ac-a3f0-e9759b4e8733,f33b515b-2d19-4bbd-86dd-c84c0fe7203c” is not a valid uuid with optional dashes.

Stack

NodeOperationError: The relation id "39da0f64-fe52-4a50-a38a-a0a8453e9241,465dde93-9b7c-4fd9-ae32-0863b4993d53,a68817d7-d8e2-4eff-8f59-e0ec852d6a8a,cc6d134b-cf21-45ac-a3f0-e9759b4e8733,f33b515b-2d19-4bbd-86dd-c84c0fe7203c" is not a valid uuid with optional dashes.
    at Object.uuidValidateWithoutDashes (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Notion/GenericFunctions.js:22:11)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Notion/GenericFunctions.js:240:54
    at Array.filter (<anonymous>)
    at Object.getPropertyKeyValue (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Notion/GenericFunctions.js:239:22)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Notion/GenericFunctions.js:342:29
    at Array.map (<anonymous>)
    at Object.mapProperties (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Notion/GenericFunctions.js:340:10)
    at Object.execute (/usr/local/lib/node_modules/n8n/node_modules/n8n-nodes-base/dist/nodes/Notion/v2/NotionV2.node.js:335:107)
    at processTicksAndRejections (node:internal/process/task_queues:96:5)
    at Workflow.runNode (/usr/local/lib/node_modules/n8n/node_modules/n8n-workflow/dist/Workflow.js:658:28)
    at /usr/local/lib/node_modules/n8n/node_modules/n8n-core/dist/WorkflowExecute.js:585:53

Please share the workflow

This is a simplified version, with the id’s as a single fixed comma, separated string, which I think, given this post, should work, although I’m not certain. I’ve also tried it with an array of strings, with the same error message, although looking at the shared workflow below, it seems that it translates it into an array anyway.

Share the output returned by the last node

The only output is the error and stack trace above

Information on your n8n setup

  • n8n version: 0.212.1
  • Database you’re using (default: SQLite): Postgres
  • Running n8n with the execution process [own(default), main]: own, I guess?
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker

Hey @Michelle_Avery, welcome to the community and thanks so much for reaching out. To summarize: You want to add multiple relations to a property in Notion but the node seems to wrap your comma-separated IDs into one string instead of multiple, correct? This sounds like a bug indeed. I forwarded your issue.

Hi @Michelle_Avery,
sorry for any trouble you are having because of this. We are tracking the issue internally under NODE-223 and will take a look at this shortly. If this is crucial for you are you able to downgrade to a version before [email protected], when we released a falsy bugfix?

It’s not crucial - I’m still working on building out my workflow, so I’m not relying on it yet. I’ll keep an eye out for a fix. Thank you!

Got released with [email protected]

I just installed the update and it works perfectly! Thank you for the fast fix!

2 Likes