Notion Update DB page not working on multiple Relations

Hi! When I try to update a Relation property in Notion wit 2 or more uuids, it returns the error. I tried separting with comma, with space, tried using quotes. It returnes such kind of error:

ERROR: 400 - {“object”:“error”,“status”:400,“code”:“validation_error”,“message”:“body failed validation: body.properties.Tasks.relation[1].id should be a valid uuid, instead was \" 2cd502bf-d624-4ae5-9bc9-cd495c1278da\".”}

Add another “Item” and that should do it. Just tested it and it worked fine for me. Comma-separated items in the same fields are still not supported.

Hi @RicardoE105. Yes, separate fields worked fine. But typically the number of records is unknown, so definetely needs some fix here. Hope it will be reworked.

I was trying to fix this since I’m working on some improvements to the Notion node, and it worked fine for me with comma-separated ids.

@RicardoE105, I found the error cause. I used to leave a space after the comma. It gives an error. Probably should be fixed, as it is unexpected behaviour

Ahhh, good catch. Fixing that right now. Thanks for the update.

Got added. It will be available in the next release.

1 Like