Flow does not continue after wait

flow does not continue after wait

versão 1.0.5

Fluxo para reprodução

Hi @admdiegolima :wave: Sorry you’re running into this.

Can you please complete this template, and let us know how you’re running n8n? For example, are you by chance in queue mode?

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

I’ve ran this workflow a few times and haven’t had any issues with it completing after the second wait node:

  • versão n8n: 1.0.5 (queue)
  • Banco de dados (padrão: SQLite): postgreSQL
  • configuração n8n EXECUTIONS_PROCESS (padrão: próprio, principal):
  • Executando n8n via (Docker, npm, nuvem n8n, aplicativo de desktop): Docker
  • Sistema operacional: Debian 11

there is an issue opened by someone else:

Hi @admdiegolima , sorry for the delay. It also looks like our engineering team is unable to reproduce this with your workflow, looking at the Github issue.

As you’re using Docker, can you double check your docker-compose.yml file for timezone variables, and make sure they all match? You can find information on that here: Environment variables reference | n8n Docs

They’d all need to match in order to not cause potential issues.

Also, if you have any server logs to share, that’d be helpful! It might have some errors that could tell you what’s going on.


Thank you very much for the answer, it helped me to solve it here, I just added the GENERIC_TIMEZONE parameter to my stack.

but the other day wait failed again, what can i do to help you identify the bug?


Thank you very much for the answer, it helped me to solve it here, I just added the GENERIC_TIMEZONE parameter to my stack.

but the other day wait failed again, what can i do to help you identify the bug??

Hi @admdiegolima - sorry to hear it failed again after working out well for you. :confused:

Could you please provide your docker-compose.yml file and any n8n/server logs you might have?

Please also make sure to remove any sensitive data such as credentials when doing this! :bowing_man:

I’m having exactly the same issue with ‘Wait’ node. I have set it to continue after only 1 min and all it does it get stuck waiting, and never comes out of it. I’ve even tried to put the Wait node in different positions in the flow but it makes no difference.

I’m on the latest stable cloud version.

UPDATE: I’ve noticed has resumed, but its taking much longer than 1 min… probably more like 3-4 mins, even though only 1 min is set.

UPDATE 2: I think I’ve realised what the issue is with n8n cloud, is that the n8n workflow Editor when executed is not updating in real time so it even though the Wait is set for 1 min, behind the scenes it is actually working and waiting 1 min before continuing, but visually watching the Workflow in Editor mode it looks like the Wait is stuck in a constant cycle for about 3 to 4 times the amount of time, and then the flow suddenly updates itself (this is the situation of following a Batch process after the Wait).

1 Like

Hi @spessex - sorry to hear you’re running into this!

Would you have any workflow with some sample data that you could share on this one for testing? I’m still not able to reproduce this :thinking: Also, what version of n8n cloud are you using, and does your timezone in your n8n instance match the timezone of your browser?

Hi @EmeraldHerald

What’s the best way to send you the sample data?

On Latest Stable 1.1.1.

Im on UTC +1 London so I would imagine its correct.\



Hi @spessex :wave: If you could provide it here in JSON format with no sensitive data, that would be great! If it does contain sensitive data, can you DM me? It looks like your wait node comes after an Airtable node, I can try sending on some of the sample data over to my own Airtable instance and see if I can reproduce this.

Have sent DM. struggling to send code as there’s too many characters for this messaging platform. Is there a way to send the actual JSON file?

Messaged you back with some options :slight_smile:

Your workflow requires credentials that I wouldn’t have, but after trying to mess around a bit more with Airtable and a wait node, I still can’t see this behaviour with an execution :thinking: Would you have some test data that you might be able to share (that doesn’t require credentials or have sensitive information) that I could maybe try and test with?

When I get some time later, I’ll do a screen recording so you can see what I mean :slight_smile: I’ll send the link to support from my Google drive.

1 Like

Any news for this topic? The problem is still here.

Hi @admdiegolima - can you please make a new thread and fill out the template, if you haven’t already? A workflow where this is happening that doesn’t rely on outside credentials would be helpful.