Git node - support for auth with access token?

Describe the issue/error/question

I cannot use the git node, because support for password authentication was removed on August 13, 2021. There is no other way to authenticate than with password. Is it possible to authenticate with access token, or is this a planned feature?

What is the error message (if any)?

ERROR: Cloning into ‘.’… remote: Support for password authentication was removed on August 13, 2021. remote: Please see About remote repositories - GitHub Docs for information on currently recommended modes of authentication. fatal: Authentication failed for {repo_name}

Please share the workflow

You can just recreate the workflow by having a single git node and trying to pull any repository.

Information on your n8n setup

  • n8n version: 0.209.0
  • Database you’re using (default: SQLite): SQLite
  • Running n8n with the execution process [own(default), main]: own
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: Docker/K8s

Hi @mako, welcome to the community!

I am sorry to hear you’re having trouble. I am not aware of any specific plans for the git node, so I have converted your question into feature request. Make sure to vote on it.

As for a workaround, is there a chance you can use the GitHub node instead of the git node? The GitHub node supports additional auth options.

Alternatively, if you want to use data from your file system directly, perhaps you can call git directly through the Execute Command node?

hi @MutedJam thank you!

Where can I vote on this feature request? I’d definitely upvote it but I can’t find a link.

Re. the workarounds:

  • the problem with the GitHub node is that the workflow would need to be able to clone a repository, create a branch, upload new files and then open a new PR. I don’t think all these steps are possible with the GH node (I think some are also not supported via the GH api)
  • I haven’t thought about the execute command, that might be an option! I’ll have to try this out, thanks for the suggestion.
1 Like

I’m so sorry - I forgot to actually change the category :see_no_evil:

You should now see the button in the upper left corner of your post (it’ll say “Vote” for you, I have just used up all my votes already which is why it says “Limit” for me):

1 Like