Gitlab Trigger 404 Project Not Found. Need help

I’m trying to set up a Gitlab to Telegram notification workflow, but I cannot link to the Gitlab project.

I’ve already set up the Gitlab Oauth2 credentials and tried entering the project namespace in the Repository Name field, but I got a GitLab Trigger: 404 Project Not Found error.

I’ve set up a sample project, Oshane Bailey / plain-html · GitLab to test the connection and entered the information for it as seen in the screenshot below:


What am I doing wrong?

Information on my n8n setup

  • n8n version: 0.215.2
  • Database: SQLite
  • Running n8n via: Docker

Hey @b4oshany,

Welcome to the community :tada:

I have just forked the repo you linked to and it has worked as expected for me, Are you using a self hosted Gitlab instance?

Just to double check as well is your Webhook URL localhost or is it correctly using your domain?

At the moment, I’m running it locally to do some testing before I deploy

Did you put plain-text as the Repository Name?

Hey @b4oshany,

I did indeed…


When you say you are running it locally is that Gitlab? I would double check the Webhook URL as well as if it is http://localhost:5678/xxxxx it will likely fail as Gitlab probably won’t be able to connect to it.

I’m running n8n locally, and trying to connect to

Perfect, And what is the URL for the webhook URL?



Hey @b4oshany,

So that will probably be it, Gitlab isn’t going to be able to reach that URL to send the notification. You can either try the tunnel option or if you have a domain set up you can set the WEBHOOK_URL env option to your domain and it should sort it out.


I deployed it and everything is working. Thanks for your help


Hey @b4oshany,

Perfect, Glad you are up and running.

Same… I’m excited to explore the list of possibilities

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.