Google Sheets Bug (?) - Can't Activate Workflow


I’m facing an error when using GoogleSheets “Append Or Update” Trigger. I get this error when saving the workflow

" Workflow could not be activated:
There was a problem activating the workflow: “Cannot read properties of undefined (reading ‘!ref’)”

I’m using N8N Version 0.233.0 installed via Cloudron.

Ps : All other Triggers are working well except that one

Hey @KevinK,

Can you share a screenshot of the settings you have for the node?

This is my enttire setup…

and this is the Sheets setup…

Hey @Jon ,

I have replicated the Google Sheets trigger node configuration that shows @KevinK and the bug is found when the sheet containing the data has been renamed.

If the sheet contains the default name assigned to it by Google Sheets, as shown below, the trigger executes correctly.

If the sheet is renamed with another text string, the Google Sheets trigger does not allow to activate the workflow showing the error that @KevinK comments.

I have reproduced the workflow in two instances of n8n running on Cloudron in versions 0.233.0 and 0.232.0 respectively and the behavior is identical in both.

If it is a rename that makes sense as the sheet the node is looking for wouldn’t exist so in theory it would need to be deactivated and activated again.

@KevinK did you rename your sheet?

Thanks @martinhache for that - I’ve indeed found it to work when using the default GoogleSheets name. The workflow has activated



So does this mean for “Added Or Updated” Googlesheets Trigger that’s the official solution or it’s a workaround for the time being?

@Jon Still, once you disable the workflow and try to re-enable it, the error appears.

I have even tried using the By ID option and the error appears when the sheet has been renamed.

@martinhache that is strange and unexpected I would expect it to work assuming the ID doesn’t change on the rename which would be a surprise. I will do some digging on this Monday morning to see what I can find.


I am experiencing the same problem with the Google Sheets Trigger. It started after I renamed the sheet. Even when I tried using the sheet id (0) instead of its name in the node, it still did not solve the issue.

Try using the default name allocated by Google Sheets…

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.