[Help needed] Any way to add http proxy to all n8n nodes via Docker Compose?

Hey, I wish to Google Palm API on my VPS server, yet my server is geo-blocked from using it.

Is there any way I could bypass this geo-blocking?

At first, I’m thinking to use a VPN client called gluetun together with n8n, and it works… but it is very memory intensive (=300 ram) in my 1.5gb ram VPS hosting.

That’s why I’m thinking about using http proxy in the docker container, but currently I’m not sure if this is feasible for Google Palm API node.

Hope for help. Thanks in advance.

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

This is problem context of using Google Palm API as my server is geo-blocked from using it. Just for your reference.

Hey @TAN_YONG_SHENG,

We can’t advise on ways to bypass restrications that have been placed as it would be in breach of the terms of service for what you are using.

However… I can answer one part of your question, Docker does support http and https proxies that can be set for a container. You can find the Docker documentation for this here: Configure Docker to use a proxy server | Docker Docs

I would recommend using an https proxy though as you may run into issues if you just use an http proxy.

Got it, thanks a lot

1 Like

Just to update purposes, I finally used gluetun vpn with a few settings suggested by craxkerjack86 which could reduce the memory usage from 300 - 400 MB ram to around 70 MB ram. This works well on my server with only 1.5gb ram (as of the writing)

https://www.reddit.com/r/selfhosted/comments/18bfb1n/comment/kd1pw0y/?context=3

Btw, may be a bug here, when the chatbot is installed via CDN: @n8n/chat - npm , it does not show any way to input our text inside to the chatbot.

For your info, here is how I embed the chatbot to the body of my website via CDN method:

<link href="https://cdn.jsdelivr.net/npm/@n8n/chat/style.css" rel="stylesheet" />
<script type="module">
	import { createChat } from 'https://cdn.jsdelivr.net/npm/@n8n/chat/chat.bundle.es.js';
	
	createChat({
		webhookUrl: '<MY WEBHOOK HERE>',
		webhookConfig: {
			method: 'POST',
			headers: {}
		},
	target: '#n8n-chat',
	mode: 'window',
	chatHistoryKey: 'chat_history',
	chatInputKey: 'chat_input',
	metadata: {},
	showWelcomeScreen: false,
	defaultLanguage: 'en',
	initialMessages: [
		'Hi there! 👋',
		'This chatbot is powered by Large Language Model',
		'My name is Yong Sheng. How can I assist you today?'
	],
	i18n: {
		en: {
			title: 'Hi there! 👋',
			subtitle: "Start a chat. We're here to help you 24/7.",
			footer: '',
			getStarted: 'New Conversation',
			inputPlaceholder: 'Type your question..',
		},
	},
});
</script>

Check out the chatbot I’ve installed here: https://tanyongsheng.net/

seems like it’s fixed now… don’t know why, suddenly it’s ok

1 Like