Heroku n8n app update fail

Hi All :slight_smile:

Describe the issue/error/question

n8n was deployed on my company Heroku as a separate app a year ago. Since then it’s not been updated.
Last week Heroku stoped providing free postgre DB so we lost our workflows.

I was able to recover the database and our workflow however I cannot update n8n to the current version.

What is the error message (if any)?

When I type “npm list -g”:

I see that my n8n is version 0.153.0. The most recent version is 0.208.1 (which enables for private app key from Hubspot).

I used ‘npm update -g n8n’ to update my version, here’s what I think are the main parts of the log:

Summary

(node:3) Warning: Setting the NODE_TLS_REJECT_UNAUTHORIZED environment variable to ‘0’ makes TLS connections and HTTPS requests insecure by disabling certificate verification.
(Use node --trace-warnings ... to show where the warning was created)

added 534 packages, removed 136 packages, changed 808 packages, and audited 1343 packages in 5m

121 packages are looking for funding
run npm fund for details

13 vulnerabilities (8 moderate, 5 high)

To address issues that do not require attention, run:
npm audit fix

To address all issues possible (including breaking changes), run:
npm audit fix --force

Some issues need review, and may require choosing
a different dependency.

Run npm audit for details.
npm notice
npm notice New major version of npm available! 8.1.2 → 9.2.0
npm notice Changelog: Release v9.2.0 · npm/cli · GitHub
npm notice Run npm install -g [email protected] to update!
npm notice

I tried running npm install -g [email protected] and npm update -g npm to no avail.

When I run ‘npm list -g’ I see that none of my depencies are updated.

Information on your n8n setup

  • n8n version: 0.153.00
  • Database you’re using: Heroku PostGre Mini
  • Running n8n with the execution process: default
  • Running n8n via : npm on Heroku

Happy Holidays and thanks to whomever might push me a clue on this :wink:

Hi @Maxime_Mathey, welcome to the community :tada:

Make sure to take a backup of your n8n data just in case before upgrading so many versions at one.

As for the problem, what happens if you run npm install -g [email protected] (or npm install -g [email protected] respectively)? Any errors?

Also, could you run which n8n (just to make sure the n8n command actually points to the right version of n8n)?

Hey @MutedJam, thank you :raised_hands:

I made sure to back up my n8n data thank you,
When I run npm install -g [email protected]it does not update, here’s the log.
Same for ‘npm install -g [email protected]here’s the log

I tried runned ‘npm explore -g [email protected]here’s the log

I tried npm update-g [email protected] and npm update-g [email protected] aswell with no success (when I run ‘npm list -g’ all packages are the same version as before trying to update).
it seems I cannot update anything, do you think it can be an Heroku permission problem? (their support didn’t imply so).
I am member, not admin on Heroku.

When I run npm install -g [email protected] it does not update, here’s the log.
Same for ‘npm install -g [email protected]here’s the log

It looks to me these commands worked, at least I can’t see an error at the end. So I am not quite sure what the problem is based on the information provided so far I am afraid. Using which command are you launching n8n on your system?

I’m not sure I understood your question sorry.
I launched those commands using the “run console” option from Heroku.

As on how I access n8n I just use the domain set up through Heroku Settings for the App.

I am afraid I am not familiar with how your Heroku Dyno is set up. In the docs we suggest using Docker, but that doesn’t seem to be what you are currently using.

So there is likely something Heroku-specific at play here, but I do not know much about that platform unfortunately. Last time I used them an app upgrade required using their CLI tool. So you might need to check with whoever set this originally up on your end how exactly your setup looks like and what the update process exactly looks like for you.

Thank you @MutedJam.
I’ll dig internally and update here with the solution when I find one :slight_smile:

1 Like

If you can’t get more insights here but want to use an up-to-date version of n8n, you can always set up a new instance btw :slight_smile:

On Server setups - n8n Documentation we have a few guides for popular services (such as Digital Ocean or Google Cloud, and also including Heroku). I also wrote a private guide for Oracle Cloud a while back (who offer a sweet free tier as @David_Go pointed out).

Copying workflows over should also work fine across different versions of n8n as long as the destination is newer than the source (and not the other way around).

1 Like