How to add credential to proxy parameters for all nodes?

Hi,

All our request on the network at work is behind a secured proxy.
To work, a request should be sent to the proxy with authentication (by certificate or by user/password).

When I do this command export http_proxy='http://proxy.here.local:3128' && export https_proxy='http://proxy.here.local:3128' it’s working for cURL.

But the general proxy parameters are not used by n8n.

I tried the optional parameter of node “HTTP request” with the parameter proxy. But it’s not working neither with http://proxy.here.local:3128 or with http://user:[email protected]:3128 (and this option is horrible for security reasons).

Currently n8n is working only with local servers. It’s interesting, but we loose A LOT of interest of n8n…

What can I do :sob:

Information on your n8n setup

  • n8n version: 1.171.1
  • Running n8n with the execution process [own(default), main]: : on unix service
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: npm

Thank you for your help,
Julien

1 Like

Hey @JulienDelRio, I am afraid the HTTP Request node is the only one allowing the use of a proxy server :frowning:.

Seeing you’re looking for a global setting I’ll convert your question into a feature request so you and other community members can cast their vote on it.

Our production environment only allows egress via a proxy. So we’re unlikely to get anywhere without some support for global proxy settings.

1 Like

Ok thanks

Wow can I promote this request ? :rofl: