How to bypass this sign up form to get the sign in one when coming back on n8n?

After signing up, I cant sign in when I come back on the site. I have always the sign-up form with no link to the sign-in form. How can I bypass this sign up form to get the sign in one? What did I miss?

Self hosted n8n on linux.
I am using the lastest docker image (1.16) with sqlite database.

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @techSG,

Welcome to the community :cake:

If you are seeing the sign up page I suspect the volume is not being correctly configured for the database. Do you see the issue when you load the page or after you restart the container and load the page?

Thanks Jon,

I would say both. Usually, on a signup page, you have an “already registered? signin.” link which allow you to be redirected to a signin form. Here I just have signup page with no way to access a signin page (even in manually changing the url). How can I do to signin when I have already signed me up?**

Hey @techSG,

It sounds like there is something wrong with your configuration, can you share how you have n8n running and what your config looks like.

Yes of course.

I am deploying your last docker package (docker.io/n8nio/n8n:latest).

I tried to do on 3 different platforms:

  • on Azure application container
  • AWS app runner.
  • on localhost using Docker Desktop.

I am using the default sqlite database but I did not configure anything for it.

I am setting the following environment variables:

  • N8N_DEFAULT_BINARY_DATA_MODE: filesystem
  • N8N_EMAIL_MODE: smtp
  • N8N_EMAIL_HOST: smtp.gmail.com
  • N8N_EMAIL_USER: mymailboxusername
  • N8N_EMAIL_PASS: mymailboxpassword
  • N8N_EMAIL_SENDER: [email protected]
    (I also tried without the email settings)

The network setting are as follows:

  • I am allowing entry traffic from anywhere
  • I am using the https/http protocol.
  • Client certificates can be ignored.
  • The app is using port 5678.

@Jon is there anything wrong in my configuration?

You are probably not attaching the volume. So the sqlite database is gone everytime u start the container.
No database = no saved data and so also no accounts.
That is why you are getting the signup every time, there simply is no account to sign in to.

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.