How to change /webhook url to /api (webhook-test to api-test) - self hosted

Describe the problem/error/question

How can I change the webhook url to rather be /api than /webhook/? Could this be done on a code level or somewhere else?

What is the error message (if any)?

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

Share the output returned by the last node

Information on your n8n setup

  • n8n version: latest but forked
  • Database (default: SQLite): postgresql
  • n8n EXECUTIONS_PROCESS setting (default: own, main): main with workers
  • Running n8n via (Docker, npm, n8n cloud, desktop app): docker/elestio
  • Operating system: linux

hello @gordonlotter

use the ENV vars for that:

  • N8N_ENDPOINT_WEBHOOK
  • N8N_ENDPOINT_WEBHOOK_TEST
2 Likes

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.