HTTP request sending attachment error in Chatwoot API

I’m doing an API integration with the Chatwoot service to send a message with an attachment, using the method {{host}}/{{api_version}}/accounts/{{account_id}}/conversations/{{conversation_id}}/messages method form-data melon format. There are 3 items at the input, I first load them and then send them via HTTP Request, but unfortunately only 1 item is sent and I get an error.There is an error in the logs Request proxied to Axios failed

I tried to split the items through the Switch node and check how the sending will work, and it works correctly, each item file was sent.

How can you figure out what the problem might be?
There may be a bug in the Chatwoot server as it returns this error.

Information on your n8n setup

  • n8n version:0.228.2
  • Database (default: SQLite):PostgreSQL
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system: Ubuntu
1 Like

Hi @aerostovtsev

Can you try adding multiple Body Parameters and check it? Is it going to be dynamic or always three files?

HI! The number of files will be dynamic. I tried to add an additional parameter to the body, but the error remained

@mcnaveen maybe there are other ideas what could be wrong?

1 Like

Hi @aerostovtsev

Personally, I never came across this use case.

These are the resource that might help you.

Here is the workflow you can refer to.

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.