Https:// port issue

Hi,

Reference source:N8N Installation | Docker Installation

Ran the following CLI command on my Google Cloud platform account:
docker volume create n8n_data
docker run -d -it --name n8n -p 80:443:5678 -v n8n_data:/home/node/.n8n docker.n8n.io/n8nio/n8n

Scope:
http://34.125.115.32/setup
http://n8n.devced.com/setup
https://n8n.devced.com/setup

Results:
Error with https://

This site can’t be reached
n8n.devced.com refused to connect.
Try:

Checking the connection
Checking the proxy and the firewall
ERR_CONNECTION_REFUSED

See, the screenshot images.


Do you have any recommendations to access https://port 443 without error?


Regards,
Hal

It looks like your topic is missing some important information. Could you provide the following if applicable.

  • n8n version:
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app):
  • Operating system:

Hey @DevCED-Team,

I have also replied to your support email but to be complete below is the same response for anyone else that might run into this.

Looking at the error it is saying that 80 isn’t a valid IP address, When looking at your docker run command you have set the port to 80:443:5678 which is telling docker to listen on port 443 of the IP address 80. If you use the correct syntax here it should work for you.

Don’t forget that you may also need to load in the https certificates to use if you are not using a reverse proxy.

Thank you very much

1 Like