I Can´t upgrade from 0.216 to 0.218

Hey guys

Whenever there was an update, I did it without any problems.

But I’m trying to update n8n from 2 servers and just nothing happens.

I use Docker Compose… and ran the following commands:
apt-get update
apt upgrade

docker-compose pull
docker-compose down
docker-compose up -d

docker image prune -a

As it didn’t work, I tried these commands bellow and then tried to update again:

sudo apt-get remove docker docker-engine docker.io containerd runc
sudo apt-get update
sudo apt-get install ca-certificates curl gnupg lsb-release
sudo mkdir -p /etc/apt/keyrings
curl -fsSL https://download.docker.com/linux/ubuntu/gpg | sudo gpg --dearmor -o /etc/apt/keyrings/docker.gpg
echo “deb [arch=$(dpkg --print-architecture) signed-by=/etc/apt/keyrings/docker.gpg] Index of linux/ubuntu/ $(lsb_release -cs) stable” | sudo tee /etc/apt/sources.list.d/docker.list > /dev/null
sudo apt-get update
sudo apt-get install docker-ce docker-ce-cli containerd.io

No error appear… I tried resetting the VPN and nothing updated the n8n. Any tips?

Hey @Evandro_Caruso,

When you say you can’t upgrade and nothing happens what do you mean? Does it just not update and stay on the same version or is it not starting up again? As you are using compose it would be worth checking the image name to make sure it has :latest at the end then do the pull.

1 Like

Still on same version (.216)

Docker Compose version v2.16.0

Sorry to ask, but what commando to know the image name?

The “latest” tag also is pulling v2.16.3 for me. I was actually on 2.17, then pulled latest to upgrade to 2.18, but it moved me back to 2.16

1 Like

If you look in the layers for the “latest” tag on docker hub, you can confirm it is indeed 2.16.3, updated 6 hrs ago


1 Like

When I run this command: docker pull n8nio/n8n:latest

I receive👇
latest: Pulling from n8nio/n8n
Digest: sha256:f50783b99a1dcacc7e033d4580d4ecd7539bcbb0f82b1e7e8fcb1206b57bfe26

And not the real latest👇

Ah that is annoying, for now set the version to 0.218.0 and it should sort it out.

Alright so quick update :slight_smile:

0.219.0 is currently building and that should in theory resolve the issue which might be in about an hour or so. We have made a note on this and will update our internal processes to make sure this doesn’t happen again.

1 Like

Alright Jon! Waiting… Tks!

By the way, I had tried with :0218.0 …

A lot of files was downloaded but the updated version do not changed.

Tks Jon!!!