I successfully set up a generic Twitter OAuth1 credential, but I still get a 401 error

Describe the problem/error/question

Hi! I am trying to upload twitter posts from a Notion database. I managed to get it working by using the v2 Twitter API, but now I want to add support for adding images to the tweets. As far as I understood, I need to use OAuth1 to access the v1.1 API used to upload media. I set up a Generic Credential Type with my Twitter keys and connected my account to it. The problem is that I get an Unauthorized (401) error code when I try to make a request.

What is the error message (if any)?

"401 - "{\"errors\":[{\"message\":\"Could not authenticate you\",\"code\":32}]}\n""

Thank you in advance for the help.

Hi @hrsdimitrov - welcome to the community :tada:

I created a new developer account with Twitter there, and also could not authenticate. @MutedJam and I tried to also use the HTTP request node, and couldn’t seem to get a request to authenticate through it, either.

I unfortunately wouldn’t have a workaround at the moment, but I’ve given our development team a heads up about this issue.


Hi, @EmeraldHerald.

Thank you for the fast reply. I actually managed to get it working with an HTTP node. Turns out I wasn’t passing the data property correctly and that for some reason was returning a Unauthenticated HTTP code.

My final solution ended up looking like that:

I hope that helps other people having a similar issue. Have a nice day.


Thanks so much for posting your solution - I’m sure that will help others!


This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.