IF is always outputting false after latest update

Describe the issue/error/question

IF is always outputting false after latest update

What is the error message (if any)?

no messages, but 7 larger 0 gives me false

Please share the workflow

Share the output returned by the last node

Information on your n8n setup

  • n8n version:: 0.166.0
  • Database you’re using (default: SQLite): postgres
  • Running n8n with the execution process [own(default), main]:
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: docker

Hey @samerbahri98,

I have just given it a go here on 166 and it worked as expected, can you double check the version?

That is odd, are you sure it is false and not saying there is no json data to output?


Yes, It’s super confusing I know

That looks to be correct to me as you have no data coming in to output.

If you change the dropdown at the top to false what do you see?

Nothing changes. Same if I change the type of the conditions (boolean, number, date, string…) it’s always outputting false.

I tried restarting the docker container, also didn’t work

Hi @samerbahri98
When you do not have any items this goes wrong indeed.
Have you tried with actual items going into the node? Seems to work fine for me when adding items

Could be understanding the problem incorrectly. Sorry if that is the case.

@BramKnuever I tried your suggestion on a completely different server. the problem is still there

Hi @samerbahri98

I think I am understanding the issue incorrectly.
I’ve disabled the function. And tried it with noOps behind the IF so it is instantly clear what is happening. Seems to be fine, What happens when you do the same:

This seems to fix the issue. Can you please explain to me what was wrong?

Hi @samerbahri98
I Am not sure if there was an issue to be honest, could be looking at it wrong.

In this post you show that it returns true, but it is empty because there is no data in it. This is the same for me and should be correct?

Adding the nodes after the IF just visualizes the flow better and with that the result of the IF. Especially because you have an Item without any data in it.

1 Like

That is it, the output shows it was true not false so it is working as expected. If there was data going through it or a noop coming off it the output would be clearer.

@BramKnuever no it didn’t return true at that screenshot, I said yes as in yes I am sure it is saying false while the json data is empty (referencing the previous question @jon asked me)

Hi @samerbahri98

It did show 1 item in true.
image

and 0 in false
image

You can actually see it without the NoOp but it is very difficult to spot:
image
You can see it green on the true line.

Your screenshot:

@BramKnuever Oh yeah that’s correct, sorry I confused myself :sweat_smile: thank you for bearing with my idiocy

1 Like

@samerbahri98
We all go through some Idiocy while working with pc’s and data :sweat_smile:
Just glad there is no problem and it is clear now :+1:

yeah the green tick symbol confused me into thinking it’s false because it’s near the false route

Ah, yes that does make sense idd. I guess you just changed to a new version with the new UI then?