IMAP node won't receive mails

IMAP node doesn’t receive mails anymore

I noticed that in a workflow that should be triggered by the IMAP node, no triggering is happening anymore, and it seems because the node doesn’t see any new mails.

It stopped receiving new mails around six days ago, without any changes being made to the workflow (worked fine for months before).

When manually triggering the node, it shows a number of mails, but the latest one is from around the time the triggering stopped.

I checked the credentials, and they seem fine (test connection to mail account works).

What is the error message (if any)?

There’s no error message, when triggering the workflow manually, everything seems to work well, but it doesn’t pull in e-mails newer than six days ago or so.

Any ideas would be vastly appreciated!

Thank you!
Richard

Information on your n8n setup

  • n8n version: 1.42.1
  • Database (default: SQLite):
  • n8n EXECUTIONS_PROCESS setting (default: own, main):
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Cloudron
  • Operating system: Ubuntu
1 Like

I have actually encountered the exact same issue with one of my clients, we opted to use the gmail polling node (as it was a gmail account) for instant triggers of new emails instead. After research we’ve seen lots of historical IMAP issues. This works very consistently.

Does the email you are using come with any polling nodes in n8n? I believe outlook also has one.

1 Like

Thank you for your input! Unfortunately, it’s an address handled by my domain registrar, so I can’t use the Gmail or other mailprovider-specific nodes.

I found a solution, or at least a workaround. Switching the format from “Resolved” to “Simple” triggers the workflow again as soon as new mail arrives.

I don’t need the attachments for my workflow, so it’s a good workaround for me, but I think it might be good to have a look at that node for everyone who’s in need of attachments.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.