Jira (Service Desk): Add Internal Comment / Add JSON To Jira API

Describe the issue/error/question

I would like to add an internal comment to Jira Service Desk. Internal comments are only visible to service agent users, not to customers. However, if I use the default Jira node with the Add Comment action, I can only add a public comment. According to the following StackOverflow answer, adding an internal comment is possible using some additional JSON:

    "properties": {
        "key": "sd.public.comment",
        "value": {
            "internal": true

However, it seems to be impossible to add additional options / JSON to the respective Jira node. Any idea how this could be achieved?

What is the error message (if any)?


Please share the workflow

Share the output returned by the last node


Information on your n8n setup

  • n8n version: 0.168.2
  • Database you’re using (default: SQLite): n8n.cloud
  • Running n8n with the execution process [own(default), main]: n8n.cloud
  • Running n8n via [Docker, npm, n8n.cloud, desktop app]: n8n.cloud

Hey @simon.sprankel, I don’t current have a running Jira instance so couldn’t test this first hand yet. Have you tried submitting your comment using the JSON Parameters option of the Jira node?

Hi @MutedJam, thanks for your answer! I did. However, it does not work. If I get it correctly, it is designed for something completely else: Adding a comment with rich text content. It actually replaces the comment field to allow inserting JSON from Document builder (this is also what the tooltip links to).

Oh no, I am sorry to hear that. I don’t see any other suitable option for this operation then unfortunately. You could try using the HTTP Request node to manually send the required API request to your Jira instance.

I shall also convert this question into a feature request so you and other users can leave their vote on it to hopefully have this functionality added to n8n’s Jira node going forward.

I was successful with the following custom HTTP Request node:

1 Like

@simon.sprankel Hello how are you?
You implemented with Oauth2? I’m stuck at state=YOUR_USER_BOUND VALUE field
If yes, how did you do it?

No, I am using Basic Auth as shown in the workflow :slight_smile:

I tried to use Basic Auth and it returned the message that OAuth2 is required for internal comments, thanks for the feedback, I’ll check it here :raised_hands: