Missing Slack OAuth scopes

Describe the problem/error/question

Slack bot added as per these instructions: Slack credentials | n8n Docs

Following scopes added:

{
    "display_information": {
        "name": "NewsletterBot"
    },
    "features": {
        "bot_user": {
            "display_name": "NewsletterBot",
            "always_online": false
        }
    },
    "oauth_config": {
        "redirect_urls": [
            "https://oauth.n8n.cloud/oauth2/callback"
        ],
        "scopes": {
            "user": [
                "channels:history",
                "groups:history",
                "im:history",
                "mpim:history"
            ],
            "bot": [
                "channels:history",
                "groups:history",
                "im:history",
                "mpim:history",
                "users:read",
                "users.profile:read"
            ]
        }
    },
    "settings": {
        "org_deploy_enabled": false,
        "socket_mode_enabled": false,
        "token_rotation_enabled": false
    }
}

What is the error message (if any)?

ERROR: Your Slack credential is missing required Oauth Scopes

Add the following scope(s) to your Slack App: channels:history,groups:history,mpim:history,im:history

I’m at a loss to what might be going wrong; does anyone know what might be missing here?

Hi @timd, I am sorry you are having trouble.

What exactly are you trying to do when running into this problem? Which version of n8n are you running?

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.