MySQL Node - Parameter "Query" is required - even if filled

Describe the problem/error/question

Hello Together

Tried today, on the latest version, to submit a custom MySQL query with the MySQL Node. Unfortunately I keep getting the error message “Workflow has issues
MySQL: Parameter “Query” is required.” This even though the field is filled in. The connection to the server works. For example, if I select a select in the node, it works, but if I want to submit a custom SQL query, it does not work because the node does not recognize that the field is filled.

Also I noticed, whether it has something to do with it I can not judge, that the AutoComplete function is active.

Furthermore, when I close the node and open it again, the field “Query” is always empty again, even if I had entered something before.

I have tested it with several browsers to exclude such a problem.

Am I doing something wrong or is there a bug in the MySQL Node?

What is the error message (if any)?

Workflow has issues
MySQL: Parameter “Query” is required.

Information on your n8n setup

  • n8n version: 1.8.1
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): own
  • Running n8n via (Docker, npm, n8n cloud, desktop app): Docker
  • Operating system:


HI @seljo-ch :wave: Welcome to the community :tada:

Could you provide some sample JSON data you’re trying to send over, as well? Please redact anything that might be sensitive!

Is your second screenshot the full query you’re trying to use with the MySQL node?

Hi @EmeraldHerald

Thanks for your reply. Sure.

Here some of the JSON send to the MySQL Node:

[ { "Datum": "22.09.2023", "Firma": "719", "Artikel": "133504", "Bezeichnung": "Active complete meatballs 560g", "Charge": "230901", "MHD": "15.04.2024", "Menge": "20", "EH": "CA", "Nettogewicht": "168", "Bruttogewicht": "184", "Anzahl_Pal": "1", "" }, { "Datum": "22.09.2023", "Firma": "719", "Artikel": "102504", "Bezeichnung": "Taste chicken meatballs 15 x 560 g", "Charge": "230901", "MHD": "26.02.2024", "Menge": "5", "EH": "CA", "Nettogewicht": "42", "Bruttogewicht": "46", "Anzahl_Pal": "1", "" }, { "Datum": "22.09.2023", "Firma": "719", "Artikel": "903", "Bezeichnung": "Easy Pack Active Lachs 9 kg", "Charge": "230803", "MHD": "12.03.2024", "Menge": "33", "EH": "CA", "Nettogewicht": "297", "Bruttogewicht": "313.5", "Anzahl_Pal": "1", "" }, { "Datum": "22.09.2023", "Firma": "719", "Artikel": "170040", "Bezeichnung": "Puppy complete meatballs 15 x 560 g", "Charge": "230901", "MHD": "09.04.2024", "Menge": "25", "EH": "CA", "Nettogewicht": "210", "Bruttogewicht": "230", "Anzahl_Pal": "1", "" }, { "Datum": "22.09.2023", "Firma": "719", "Artikel": "900", "Bezeichnung": "Katzenfutter Original Meatballs 7.6 kg", "Charge": "230517", "MHD": "16.10.2023", "Menge": "3", "EH": "CA", "Nettogewicht": "22.8", "Bruttogewicht": "25.8", "Anzahl_Pal": "1", "" }, { "Datum": "22.09.2023", "Firma": "719", "Artikel": "901", "Bezeichnung": "Katzenfutter Huhn und Lachs 7.6 kg", "Charge": "230517", "MHD": "16.10.2023", "Menge": "4", "EH": "CA", "Nettogewicht": "30.4", "Bruttogewicht": "34.4", "Anzahl_Pal": "1", "" }, { "Datum": "22.09.2023", "Firma": "719", "Artikel": "125510", "Bezeichnung": "Active complete mit Lachs meatballs 15 x 560g", "Charge": "230803", "MHD": "27.02.2024", "Menge": "7", "EH": "CA", "Nettogewicht": "58.8", "Bruttogewicht": "64.4", "Anzahl_Pal": "1", "" }, { "Datum": "22.09.2023", "Firma": "719", "Artikel": "170040", "Bezeichnung": "Puppy complete meatballs 15 x 560 g", "Charge": "230803", "MHD": "07.03.2024", "Menge": "5", "EH": "CA", "Nettogewicht": "42", "Bruttogewicht": "46", "Anzahl_Pal": "1", "" }, { "Datum": "22.09.2023", "Firma": "719", "Artikel": "180040", "Bezeichnung": "Active complete Protein meatballs 15 x 560 g", "Charge": "230803", "MHD": "18.12.2023", "Menge": "7", "EH": "CA", "Nettogewicht": "58.8", "Bruttogewicht": "64.4", "Anzahl_Pal": "1", "" }, { "Datum": "22.09.2023", "Firma": "719", "Artikel": "260049", "Bezeichnung": "Taste beef meatballs 15 x 560 g", "Charge": "230901", "MHD": "16.04.2024", "Menge": "5", "EH": "CA", "Nettogewicht": "42", "Bruttogewicht": "46", "Anzahl_Pal": "1", "" } ]

No no the Query isn’t complete like that. I’ve tried several.

The simplest that gives the same message was the following: SELECT * FROM stock_frigo

I have the same issue in Microsoft SQL node. SQL is not recognized and the Query field is empty after closing and opening the node.

  • n8n version: 1.8.1
  • Database (default: SQLite): SQLite
  • n8n EXECUTIONS_PROCESS setting (default: own, main): own
  • Running n8n via (Docker, npm, n8n cloud, desktop app): npm
  • Operating system: Windows Server 2012R2

n8n MSSQL node

I downgraded to 1.7.1 and there is no problem with the query.

The same problem is in the PostGreSQL node.

After upgrading back to 1.8.1 the existing query works. But if I try to change the query, it is not updated.
Seems to me as if there was a disconnect between the field in front-end and the query variable.

I can confirm, on 1.7.1 it works. No error with empty Query even if filled. And the Query will be executed correctly.

@EmeraldHerald Do we need/should we open an issue on Github?

Hi all :wave: Apologies, as I was out yesterday.

This issue should be fixed in 1.8.2, can you try upgrading and let me know if the issue persists?


Hello @EmeraldHerald

Sorry, didn’t mean to stress you out. I can confirm that it now works again as in version 1.7.1 with version 1.8**.2.**

Thank you very much.


Hi @seljo-ch No stress :slight_smile: I also just cheekily edited there, I meant 1.8.2 :sweat_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.