Query is required in postgres node

I’m on version 1.8.1

I simply cannot get the postgres node to work (Execute Query). I’m getting:

Parameter “Query” is required.

Hi @systemaddict, I am so sorry for the trouble. It looks like n8n version 1.8.0 introduced a nasty bug to the SQL editor. Can you try upgrading to [email protected] and let me know if you’re still seeing the problem?

Yes, that fixed it. Thanks.

There’s a small thing that you might want to fix. You cannot input a single value in Query Parameters without adding it as an array or suffix it with “,”

1 Like

Now that’s odd - I tried running a couple of queries like the one below (and also using expressions) on my end using 1.8.2 without getting the error you have seen. Can you share your node with me for a closer look? You can simply copy it from your n8n canvas using Ctrl+C, then paste it here on the forum using Ctrl+V.

Thank you!

1 Like

Thanks so much @systemaddict, I’ll add this to our bug tracker for a closer look and fix

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.