n8N node (get workflows)

Describe the problem/error/question

Hello guys, I am trying to get all my workflows to back them up automatically with a scheduled trigger.
However, I am not able to connect to my n8N account. I added the ApiKey for the credentials of n8N node, but its not connecting.

What is the error message (if any)?

ERROR: connect ECONNREFUSED ::1:5678

Please share your workflow

(Select the nodes on your canvas and use the keyboard shortcuts CMD+C/CTRL+C and CMD+V/CTRL+V to copy and paste the workflow.)

## Share the output returned by the last node
<!-- If you need help with data transformations, please also share your expected output. -->

## Information on your n8n setup
- **n8n version:**1.0.1
- **Database (default: SQLite):**default
- **n8n EXECUTIONS_PROCESS setting (default: own, main):**
- **Running n8n via (Docker, npm, n8n cloud, desktop app):**npm
- **Operating system:**windows 11
![Screenshot 2023-08-22 153858|671x484](upload://pILHrdFuuQpX9Es2zkLvVYK3w18.png)

Hi @Nazih_Saba :wave: That’s a bit strange :thinking: Have you tried removing the credential and re-adding it? This should work.

Out of curiosity, are you also running n8n through a tunnel or otherwise using a VPN?

Yes, I tried but no luck.
I am running n8N locally through n8N without an tunnel or VPN.

Hey @Nazih_Saba,

What host value do you have set for you n8n node credential and what url do you use when you load n8n in your browser?

Looking at your workflow you also wouldn’t need both the n8n node and the Execute Command node so you could drop the n8n node and just work with the binary output from the execute command node.

Hey Jon,
First of all thank you for your reply.

I did remove the n8N node and worked with the cmd node.

1 Like

Hey @Nazih_Saba,

Perfect, Is all good with the execute command node now?

Yes Yes, Thank you

1 Like

This topic was automatically closed 90 days after the last reply. New replies are no longer allowed.