New node building and the node not appear im workflow

Describe the problem/error/question

Im building a new node in n8n but when i run command start n8n the browser open but my node not available in action i search my new created node but we couldn’t found

## Information on your n8n setup

- **Running n8n via npm
- **Operating system:**

Hi @Waqas_Shaukat, welcome to the community. I am sorry you’re having trouble.

Can you confirm what exactly one would need to do to reproduce your problem? Have you linked your node using npm link?

Hi @MutedJam Thanks for the reply. Yes I have linked node using npm link command I do all steps mentioned in node building documentation.

Hey @Waqas_Shaukat,

Can you share the exact commands you ran and the directories you ran them in?

Hi @Jon,
I shared the screenshot.

Hey @Waqas_Shaukat,

Perfect, second npm link command you are running is being done in the wrong folder. This needs to be ran from the n8n custom folder or the nodes folder which is usually ~/.n8n/custom or ~/.n8n/nodes.

You can find information on running nodes locally here: Run your node locally | n8n Docs

Hey @Jon we couldn’t find the folder. Where can we find this way?
~/.n8n/custom or ~/.n8n/nodes .

Hey @Waqas_Shaukat,

On Windows if your username was waqas the folders would be under something like C:\Users\waqas\.n8n, It will be a hidden folder as well.

hey @Jon there is no folder named custom in .n8n

Hi @Jon i created folder custom and follow the documentation now i get this error.

Hey @Waqas_Shaukat,

Perfect so that looks like there could be an issue in your node with the aws-sdk package being pulled in from somewhere and it might not want to play ball with Windows.

So now what can we do to fix this error.

Hey @Waqas_Shaukat,

You would need to check your nodes project to see why it might be using that it could be that you need to update a dependency.

It could also be worth trying to run it in docker to see if it is just a windows only issue.

1 Like

Hey @Jon i’m trying to Build a declarative-style node i follow the all step that is define in documentation. Tutorial: Build a declarative-style node | n8n Docs
nasapic example but we face issue and error

Hey @Waqas_Shaukat,

It looks like the AWS-SDK npm package is having a hard time with Windows based machines at the moment.

so how we resolve this error

Hey @Waqas_Shaukat,

In theory a quick way to get around it would be to add your node to an n8n docker container that should work.

can you share the link ?

You can find how to launch n8n with docker here: Docker | n8n Docs

when i run build command the node not build